SketchUp 8- format no longer be available for download from 3D Warehouse


#1

Maybe you could add a newer file type import option also into native Rhino5


#2

Another one bites the dust!


(Wim Dekeyser) #3

Does anybody have any tips on how to get a Warehouse model into Rhino without having to install anything on your PC?


#4

I recently opened one that was later than 8 in the WIP - because it wouldn’t open in V5 - and then pasted it back into V5, but I have no idea what version .skp it actually was…

–Mitch


(Wim Dekeyser) #5

Well - I thought I had tried that last week. I had the impression that the WIP didn’t read anything newer than the 8 version but I must have done something wrong because now it works.
Thanks Mitch!

Next question: When I read the Warehouse sketchup file in Sketchup and export to version 8 and then import that one into Rhino 5, textures and all come in nicely in Rhino. When I import the Warehouse sketchup file into the WIP and use the Rendered display mode, the textures are missing.

Rhino 5:

Rhino 6 WIP:

Model:


(Pascal Golay) #6

Hi Wim -checking that, thanks.

@wim - it looks like you need to set ‘Use the Sketchup Texture Writer to create textures’ when you open these in V6:

-Pascal


(Wim Dekeyser) #7

Thanks Pascal!

I’m still rather confused after trying a few more things.

RH5
I downloaded the table and chairs model from the warehouse either as SketchUp 2014 or 2015 version. Opened that in SketchUp and saved as version 8 model. Imported that in Rhino and in [my slightly modified] Rendered display mode it looks like this:


The shadows appear to be the result of the … > Rendered > Lighting Scheme > Lighting method > Scene Lighting setting that appears to be factory-default.

RH6 WIP I first imported the 2015/2014 version model with "SketchUp Texture Writer" checked and placed one viewport in Rendered and one in Raytraced with this result:

Then, in another Rhino session, I imported the version 8 model and turned on the sun to obtain shadows (the Scene Lighting setting doesn't produce them here...).

I looks like all textures are read now but something's off with the scaling of the floor.

Then, when I go back to that other RH6 session (the one with the 2015/2014 version) and turn on the sun there, all of a sudden more textures are read by the Rendered display mode but not by the Raytraced mode. Turning off the sun to make textures go away again doesn't work.

(@nathanletwory)


(Nathan 'jesterKing' Letwory) #8

I don’t think the texture issuesin Raytraced have to do with lighting, but possibly is https://mcneel.myjetbrains.com/youtrack/issue/RH-38300


(Wim Dekeyser) #9

Possibly.
But the floor isn’t cylindrical, is it?


(Nathan 'jesterKing' Letwory) #10

Title is misleading, read the comments. There are problems with texture mappings and so on. Title is from initial find