simpleFoam abort code 1

Have been trying to get trees to work and having a tough time. The trees are mesh volumes that are big to encompass canopy of multiple trees.

I can get it all to run with terrain + buildings, but if I add all my trees then simpleFoam does not run at all. I had the idea that the problem is that the buildings and the tree volumes intersected, so I went around and boolean differenced all the tree volumes to no avail.

I tried processing all the tree volumes as individual trees as well as doing it as one disjoint mesh.
log_fail.txt (40.7 KB)

log_mesh.txt (199.0 KB)

Yep, EDDY doesn’t play nice with Meshed surfaces sometimes. I have also in past had problems in computing with Trees included in the simulation. I however did a tedious workaround that worked in my case.

  1. Baked the tree geometry that comes preloaded in EDDY GH script under Templates.
  2. Made new layer in Rhino - Froze all other geometry in model & placed the new baked tree at same places where i had meshed trees.
  3. It took me a while but eventually i was able to categorise new trees based on type and height.
  4. After that i made a new file brought in my building and new tree geometries and redid the run.
  5. It took i believe 2-3 tries but eventually all of it worked…Patience and simplifying the run was key in my case…

Hopefully this helps somewhat.