Multiple Tree Instances


I am new user to EDDY and have a simple question- I am running into error when I add “Multiple trees Geometries” in the script. I used the geometry component and added multiple geometries (trees) and then plugged in into the Tree component.

My Question is that - do I have to make separate tree component for every tree? Every time I am running simulation there is no result and it just crashes in between the process.

I would very much appreciate if anyone can help me understand on how to model several trees and add them into simulation. Thanks!

That phrase “simple question” always triggers me since the answers are rarely simple.

1 Like

Hi Somesh,

Couple of questions:

  1. What are your trees? Simple Spheres? Eddy has to go through and mesh each tree, which can take a while, and if they are complicated it can crash it. It is best to model them as closed simple spheres, or boxes/extrusions

  2. I do not see the portion here where you actually make the trees, it should be under or above “run sim” a “make trees” you must run this (w/ a button) before you run the sim, after you run the building mesh. Should get a pop-up and it will run through all of the trees. Can take 30 minutes or longer if you have a lot of trees on a laptop.

If you have done both of these things and it is still crashing it may be one of your simulation settings, or meshing settings.

You should not need to add each tree separately.


1 Like
  1. Yes, these are just Spheres…same ones that were in the Template. I just baked it from template and used it again in my design, they are super simple.

  2. Yes, I am aware of that. What I meant to ask was if I had to add each tree separately? Since the template did it. Now If I understand it correctly, I can group trees in “Geo” component if they are same type like dense, medium etc…Each tree type can be grouped and then added to simulation.

I see you say I DON NOT have to add each tree separately.

Ok, this should help. I’ll try it out today and see.

Again thanks for all the help much appreciated!

Sounds like it might be an issue with the simulation running, i.e. mesh settings or sim settings. Make sure you run the mesh, then make trees, then simulation. Let me know if it works. Post the file + GH w/ everything internalized if you want me to look at it.

Okay, that sounds good to me! I’ll take a first pass at it and if it still doesn’t work…I’ll upload the GH file with everything internalized. Thanks!

It worked fine this time around Remy. Thanks for all the help!

Awesome, you’re welcome! One thing of note, I am not sure what level your probing / where this is located, but 100m/s wind is extremely high… 223mph, which is like, the highest wind recorded on earth, very unrealistic for that red area to be so high in the image. How many iterations was that?

Yes, I noted that as well. It is in a hurricane zone, Corpus Christi. We took 144 MPH as design wind speeds (~64 m/s).

1000 is what the number of iterations were when I ran that analysis. I’ll message you the grasshopper file for you to take a look. I am uncertain what is causing this.

Did you put 64 m/s as the Uref (reference speed) ? That would explain it probably. If not, definitely something weird going on.


Yes, the Uref is 64m/s. I messaged you the file as well.

If you find anything that may improve the accuracy of the study let me know. I believe the trees has to do something with the unusual windspeed.


Hi Somesh,

Sorry for the delayed response. I re-did your sim from the files you sent and I got similar results, but then I changed the length of the wind tunnel and got better results that seem more realistic.

In general, you want a good amount of distance from the inlet to your objects. I think you had not enough, so simply increasing the length of the wind tunnel, to maybe 8,000-10,000m provides more distance from the inlet to the object.

In general, if you specify the Uref as 64m/s, then the max wind you should see for the most part (not in all cases) should be close to 64 m/s. So if you are seeing 100m/s…something is kinda up, or your design has a serious flaw that is making that 100 m/s…if that makes sense?

Also, you should specify ground height references, and roughness ref’s if you want more accurate info.

1 Like


Yes, that all makes sense. This was an initial design and we are actively working to sort the master plan layout in more coherent way. I will increase the wind tunnel distance as you mentioned and hope to see some better results. I’ll also tinker around with ground height references and roughness ref’s as you mentioned.

Thanks very much Remy!