ShrinkTrimmedSrf not Shrinking


#1

Hi Guys,

I’m exporting surfaces to a program called Maxsurf which tends to read the original untrimmed surface.
I have tried ShrinkTrimmedSrf and ShrinkTrimmedSrfToEdge but after each command the surface can still be untrimmed in Rhino and Maxsurf still reads the untrimmed surface.

Is there something I’m missing? or a better way of approaching this?

Cheers, Tom.


(Pascal Golay) #2

Hi Tom - Not all surfaces can be shrunk back to their trims if the trims are arbitrary. If the trims are not on isocurves, there will always be some of the underlying surface ‘sticking out’ someplace. Feel free to post one of the surfaces…

-Pascal


(David Cockey) #3

ShrinkTrimmedSrf and ShrinkTrimmedSrfToEdge shrink the underlying surface to isocurves, not the trim curve unless it happens to coincide with one or more isocurves.


#4

Thanks for the fast response.

I’ve attached one of the parts I’m trying to keep trimmed.

Is there a way of generating an isocurve at the desired trim location?

I had some much more complex surfaces that I have since rebuilt using ExtractWireframe and NetworkSrf

Tunnel Plate.3dm (94.2 KB)


(Pascal Golay) #5

Yep - if you turn on points for this surface you can see that the underlying surface is still there in the notch - it is not trimmed on an isocurve there on the long side of the notch. There is no way around it - if the target application cannot see trimmed surfaces as trimmed, you cannot use this surface as is. However you can split it in two, in this case and suck the smaller part over to thge trim curve using MatchSrf - I’m not sure if that will work for you. To be a little more sure, I moved the points by hand over to that red curve in the file before matching and I used the 'match by closest points setting. To move the points with some control in this particular case, use Ortho or Gumball, but in an arbitrary orientation, you can force points to stay locked into the line to the next point (the ‘control polygon’ segment) by setting DragMode to ‘ControlPolygon’.

Tunnel Plate_PG.3dm (130.0 KB)

-Pascal


#6

It’s more that the target program struggles when importing a large number of trimmed surface and usually crashes.

As annoying as it is, I’m just going to split the model up into smaller chunks and bring it in.

I hadn’t used matchsrf before and looks to be super handy for some of the things I do in rhino. But you lost me after that.

Thanks for your help, maybe a dev will see this any it may become a future feature.


(Pascal Golay) #7

Hi Tom - I posted a modified file above - you might give that a try and see if there’s any hope in taking that approach.

-Pascal