Shear - no longer allows small angles - snaps to large angle

I am trying to use Shear to shear a polysurface. I used points to shear the polysurface so the top edge moves in 1mm increments.

  1. Select polysurface.
  2. Shear
  3. Select 0,0,0 as shear origin
  4. Select first point
  5. Select 1mm, 2mm or 3mm point to shear object.

The first attempt worked perfectly and I added a 1mm shear to the top edge. When I tried to do the same thing to create a 2mm and 3mm shear it tries to create a much bigger shear and seems to snap to a minimum angle either direction…


I cannot work out if I have done something to cause this behaviour or if it is a bug.
I cannot recreate the 1mm shear.
Can anyone see what I am doing wrong or if this is a bug?
Attached is the rhino file with the original and the successful 1mm shear.
Shear_Bug.3dm (221.5 KB)

EDIT: Answered my own question… I was snapping to the end of the top edge of the polysurface for the first reference point instead of point0. This was actually (0,0,-22) which was causing the weird snapping behaviour.