Transform:Shear help


#1

Newish to Rhino, new to forums.

Help appreciated. I have been trying to create an axonometric view. I have done this many times in the past, but now I cannot seem to do it, tried different computers etc.

one of three things happen anytime I try the shear command:

  1. I am asked to choose an origin point, then a reference point, but nothing after (angle, etc), the command line just goes to “command:” as if I had done nothing.

  2. The shear (at -45) creates a monstrously long and paper thin model (like one that extends 10-20 times past the cplane kind of long)

  3. The model becomes infinitesimally tiny (-45 angle =, as well, just different origin points.)

does anyone have any experience with this?

thanks


#2

It sounds like where you are snapping for your axis reference points is maybe not where you think you are snapping to? Can you see the reference axis as vertical in both the Front and Right views?

If you have a model that reproduces this phenomenon please post it (with instructions), as it will help diagnose the problem.

–Mitch


(Menno Deij - van Rijswijk) #3

Have you tried this

! _Select _Pause _SetActiveViewport Top _Rotate 0 30 _SetActiveViewport Right _Shear w0 w0,0,1 -45 _SetActiveViewport Top _Zoom _All _Extents

Taken from http://www.sketchygrid.com/index/tutorials/rhino-trick-axonometric

As you can see the first and second coordinate are given in world coordinates ‘w0 w0,0,1’. As @helvetosaur was saying, that may be the cause of the problem?


#4

Hmm, it’s always fun to see that the little tutorial that I made for creating an axonometric has made its rounds… :smile:

http://enac-oc.epfl.ch/page-43529-fr.html

–Mitch


#5

Thanks guys.

The script worked like a charm.

Playing around with it, I think my issue was that I was choosing the reference point on the model. (I thought it could be any vertical point, not just a vertical point higher than the object)

PS @Helvetosaur your little tutorial has not only been getting around, they teach at school (arch), though they made it sound like they had come up with it (because they were working with specific axon parameters)