Shapediver Embedding our own model

I am trying to create our own model (as a PRO user) to be embedded on our website, but I am not yet able to view my model. So NOT as an iFrame, but embedding it using JS api.

Given this codepen:

And adding our own backend ticket in the panel on the right, I would expect that the shapediver viewer will show my model. But it is only showing the shapediver logo.
I also tried to use the ‘ticket for direct embedding’, but this also doesn’t work.
Also whitelisted the domain when configuring the model.

What can be the cause of this?

Cheers, Nico

The correct ticket is the ticket for direct embedding. In terms of codepen, the correct domain for embedding is (can be checked in the browser console). Let me know if adding this domain solves your issue, otherwise please point me to the model you are having issues with.

I wasn’t able to solve the problem. I changed the model to public, added the domain, and tried with the direct-embedding ticket with no luck.

Here is the link to our model we are testing with:

Thanks a lot for your help with this.

I just copy pasted the “Ticket for direct embedding” in the codepen you linked above ( and could see your model without issues:

Thanks Mathieu.
I do appreciated your help, thanks !!

Well, it’s odd, because the ticket that you pasted in, is totally different from the one that I got out of the shapediver system. For example, the ticket that I used did not have a dash - sign at the near end.
So that must be the problem I guess.
I will try to find out why that is.
Using the ticket in your screenshot is indeed showing results. Thanks a lot.
Cheers, Nico

Hi Mathieu,

here a quick update.
Still we did not manage to use the ticket for direct embedding

Please review this screenshot:

So we use the ticket for direct embedding, starting with 2f05… etc
If we use this in the codepen: it does not work

We also try the ticket for backend, starting with 3d23… etc
If we use this in the codepen: it does not work.

We provided a public accessible page, and you manage to get a completely different ticket that is working in the codepen. But your ticket in your previous screenshot starts with 6f72… etc.

So my question is:
What am I missing here?

In my opinion it should be relatively simple to use our ticket that starts with 2f05…
How did you transform that into a working example?

Cheers, Nico

@user563 when working with Codepen please whitelist both and Whenever you freshly load your example on Codepen the domain they are hosting your example on might change (don’t know why they do it like this, but that’s the way Codepen works).

If this doesn’t solve the problem you maybe did not copy the complete ticket (although it gets selected completely when you click into the box). Make sure that you select all of it until the very end please.

Please note that it’s ok for the ticket to be different every time you load the model view page.