Shaded mode extremely slow (approx. 2fps), rendered view is fluent

I thought I already postes this some Months ago but I didn´t as it seems :).
Also the topics i found about this problem don´t seem to fit to mine…
Sometimes files imported (as .stp Blocks), make it impossible to work with in shaded mode.(everything else works also fluently, only the viewport is on 2fps). The Rendered mode or Wireframe Mode are working as fluent as it should be though. I mean shouldn`t the Rendered-Mode be way more “thirsty” in terms of performance? The File is 380mb and consists of 402 single and 898 polysurfaces after I exploded the blocks and deleted them in the BlockManager. Also my Laptop should be capable of dealing with the load. Unfortunately I cannot post images or a Video since its still in development and not yet released. I can post my System info.
Thanks in advance!

System Info:
(I am working on a UWQHD 3440 x 1440 Resolution with my Lid closed)

Rhino 7 SR8 2021-7-15 (Rhino 7, 7.8.21196.05001, Git hash:master @ 45c1fd6dc85c7c1cce8c0bbe6f3e16481ae9abfa)
License type: Commercial, build 2021-07-15
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro T2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 9-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.08
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 5-5-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-13-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21196.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

You are behind by quite a few service releases. I’d update first to latest and see if that helps.

1 Like

I do think your rhino 7 version is too old.
The latest version is 7.17 and yours is 7.8 in mid last year.

1 Like

Oh, good hint! Maybe i deacitvated the auto-update

I recommend using Fraps or Bandicam to show your frame per second (fps) in Rhino viewport.
Make sure these recording software are switched to game recording mode.

Then you can use Rhino command “TurnTable” and slide the speed to 50 or so.
The current fps will be shown in the corner you assigned.

In this way you may have a much more accurate grasp on the performance in each display mode.

Or just use TestMaxSpeed.

Updating did the trick, I feel so dumb, sorry :smiley:
Gotta fix the auto-update so this won´t happen again.

This is super! I did not know this. It seemed the command comes as early as rhino5. At that time the only thing I know is holomark use turntable to test display performance.

Pretty handy indeed, good to know