Section Tools missing surfaces

I’m having some issues with Section Tools missing closed polysurfaces when creating surface/hatch faces. They’re fully closed polysurfaces; I’ve tried SelBadObjects with no results, I’ve tried showing naked or non-manifold edges with no results. I’m not sure why it’s missing objects!

What would cause Section Tools to miss objects?

This solution worked for me: use the command stEditSectionsObjects to add the offending surfaces.

I ran into issues because I ran a Boolean operation on the polysurfaces, which broke the Section Tools reference.

Hello - I don’t know - can you post an example, with the details of what command(s) you’re using?


@pascal - Unfortunately I can’t; I can’t even remember which project I was working on in Sept 2016 to be able to provide an example.

Hopefully, since then, I’ve been better about posting examples with my questions!

On a side note, we’ve largely stopped using SectionTools in Rhino 5 because of issues with hatch patterns and some quirks with detail views.