Scaffold design but invalid mesh

Hi community, (10.3 KB)

I tried to get mesh from vortices and the model attached but I get invalid mesh error so that ı am not able to finish my work. I appreciate your advice…

You didn’t internalize your geometry in the file you posted so I used a simple cube that I created.

If you preview the output of your Construct Mesh component, you’ll see that you’re not getting regularly shaped quad faces:

If you change the order of the inputs to the Mesh Quad component you will get regularly shaped quad faces.

You should be able to proceed from here.

I internalized the geometry I was using (simple cube). (15.6 KB)

I used the Tree List Viewer created by @Joseph_Oster to troubleshoot this. You can find this very useful tool here:


Thank you Kevin after your correction I worked on my file, but I had no progress about what I want.
I want to do some kind of boolen operation and finaly I want to have structure as seen in the picture. I am new on rhino thats why I stuck. Thanks for your considerations

Check this old forum classic…


Thanks a lot HS_Kim