RunPythonScript broken in Build 2014-06-23


#1

The dialog doesn’t appear at all. I’ve been in and out of Rhino all day without any issues, updated to the new build two minutes ago. I’d love to give a better report, but it’s not a crash so I don’t have much to go on.

  1. Execute RunPythonScript
  2. Message bar echoes “Command: RunPythonScript”
  3. Command seems to exit successfully, but no window appears.

Run python script not working in Rhino mac Wenatchee 27-8 (523)
#2

Happening here as well. All script, IronPython, etc. folders seem in place.

Thanks, could use this.

Randy


(Steve Baer) #3

Thanks for the reports guys. I’m working on a fix.


#4

Eta? Can we rely on a previous build?


#5

I still had the dmg for the latest build and went back to using it until a future build fixes this issue.


#6

Would you happen to have a link to the previous dmg? I’m having trouble finding it.


#7

See if this works for you: http://files.mcneel.com/Releases/Rhino/5.0/Mac/rhinoceros_wip_20140610.dmg

It seems that if you know the build date simply requesting the file is enough. The EULA prohibits redistribution and McNeel doesn’t provide file hashes, otherwise I’d always share the old images I use to roll back when regressions like this occur.


(Steve Baer) #8

I just released a new version of python for Mac Rhino that should work with the latest build.

http://www.rhino3d.com/download/IronPython/5.0/wip


#9

Hi,

python definitely works with the new build, but I’ve come up against a different problem.

As a result of calling res = rs.MessageBox ("Keep original objects", buttons=259) I get the following error:

Do you have a suggestion for fixing that bit of code?

thanks
Peter


(Steve Baer) #10

I’m in the process of fixing functions that show user interface (like message boxes). This should be fixed in my next python release.


#11

What’s interesting is that it’s looking for 4 arguments and in Windows there are only 3 maximum… What 5 arguments did you feed it?

Edit: ah, I see:

Rhino.UI.Dialogs.ShowMessageBox(message, title, btn, icon, defbtn)

Wonder which one is missing? I don’t know what a message box is supposed to look like on Mac…

–Mitch


#12

No worries,
totally understand!
Cheers
Peter


#13

I just downloaded the new Rhino Mac (wip_20140630). After installing IronPython (python20140630) I can run scripts, but when I try to generate a textile via the python script it does not create the txt file. I also don’t get any errors and I know that the script is woking correctly. Any ideas on how to fix this?
Thanks!


(Steve Baer) #14

I just released a new python build (July 1, 2014) for Rhino that should fix some of the dialog related issues that you guys are seeing with the release from yesterday.

http://www.rhino3d.com/download/IronPython/5.0/wip


#15

Unfortunately, can’t test tonight, left my Mac at work… Will try tomorrow.

–Mitch


#16

The update fixed the wrong number of arguments error but seems to have introduced a new one:

The error:

The (apparently) offending line:

dialog = rs.MessageBox("Host: " + host + "\nPort: " + str(port), buttons=65, title="Launch REPL server")

Everything was working on the 20140610 build with IronPython 2012-something. Please advise (and thanks for keeping up with all of this!).

Edit: I should note that this issue is with the latest WIP and IronPython 20140701.


#17

Did MessageBox() ever work on Mac? My experience was that pretty much all of the …Box() methods failed on Mac previously because they all call WindowsForms… I know Steve is working on getting this stuff going on the Mac side, but up till now, I have had to avoid all of these methods for Mac scripts.

–Mitch


#18

MessageBox() has worked as long as I’ve been using it, which is almost >2 years by now and was fine until yesterday. I can’t recall which (if any) of the others worked, except that EditBox() definitely did not work else you’d definitely see a few EditPythonScript.py floating around…


#19

OK, then this is for @stevebaer then…

–Mitch


(Steve Baer) #20

Yep, MessageBox was probably the ONLY one that did work. I’m in the process of getting the other user interface pieces working, but it also involved a whole lot of rearrangement to code (which is why we are seeing some new bugs crop up.)

I’ll try to get a new python build out tomorrow.