Rs.Command(_Insert) is losing object names

I’m revisiting some code I wrote in 2013 for Mac Rhino, which worked fine at the time, but no longer works. . One problem I’ve isolated is that after I make this call:
rs.Command("-_Insert _File=_Yes _LinkMode=_Link ArmSpec3 _Block _Scale 1 _Rotate " and then explode the block, the name of the objects from the "_insert"ed file are not there. They definitely used to be back in 2013, since my code relies on being able to find them by name. If I change _LinkMode=Embed, the object names are retained after exploding the block, but I need to use Link mode.

Any idea what is causing this? Barring that, any suggestions for a workaround? Is there some other way I can perform this insert? Is there still no rs.Insert() command available?

Are you sure it worked if you inserted it as a Block instead of Group or Object?

If you do insert it as a Block then the names will stay if scripting the Explode command instead of using ExplodeBlock.

Does that help?