Rhinoscript plugin not enabled by default

A student with an educational license not able to run plugins - turned out her rhinoscript plugin was not enabled in the plugin manager.

just reporting in,
K

I think we’ve seen this in the past when some antivirus software thinks that the RhinoScript plugin is suspect.

this is the antivirus installed: https://www.avast.com/en-gb/index#pc

Is there a way to turn rhinoscript on via a toolbar macro?

thx

That’s all I really know about the situation. @dale mentioned it to me recently

Hello - it looks like you can load, but not enable, a plug-in with a macro:

! _-Options _Plugins _Load RhinoScript _EnterEnd

It looks like RhinoCommon lets you load and enable - here’s a Python:

import Rhino 

def test():
    
    id = Rhino.PlugIns.PlugIn.IdFromName("RhinoScript")
    Rhino.PlugIns.PlugIn.SetLoadProtection(id, True)
    Rhino.PlugIns.PlugIn.LoadPlugIn(id)
    
test()

-Pascal

1 Like

Hello,
I met with the same problem. Is there a way that can enable the plug-in automatically. For now, I need to choose use this plugin manually before Rhino is used, every time.

BTW, I didn’t understand well your reply. Is it a method can help for my problem?

Best,

Hi - If you also have Rhino 7 WIP installed, please try first uninstalling the WIP and then installing the latest version.
-wim