RhinoCommon v5 Template for VS 2019


I recently returned from a brief hiatus in developing plugins for Rhino 5, and I was reacquainted with the issue of using the existing template in VS versions higher than 2015. As such, I learned how to create a template of my own and figured out how to create a v5 template file for VS 2019. I thought I’d share it here to provide an easy solution for others who have also had to deal with this issue!

1 Like


I have tried to install your template in VS 2019 community edition . It was installed properly but it is not visible in the list of templates when I start VS …

can you please give further instructions how to use your template


Hello Aleksandar,

That’s interesting, all I had to do was click on the .vsix file to install it, restart all running instances of VS (otherwise the template won’t load), and then locate the template in the “New Projects” window. Here are screenshots of the steps I took:

Opening “Manage Extensions” shows me this:

While this doesn’t directly relate to your question, I should mention that I do not yet know how to make the template change the name of the initial files and classes depending on the inputted project name, and so you’d have to manually replace “RhinoCommonv5TemplatePlugIn” and “RhinoCommonv5TemplateCommand” with whatever names you desire (but it shouldn’t take too much time, maybe less than a minute of work).

Aside from those things, I didn’t do anything else special (unless the template only works on my machine somehow). Let me know if you have any further questions!


You don’t actually need the template for R5. The R6 template works just fine for R5 development and works in VS 2019. https://marketplace.visualstudio.com/items?itemName=McNeel.RhinoCommontemplatesforv6

Just reference your R5 Rhinocommon.dll

I just tried to do so, and while it allowed me to use the V5 Rhinocommon, it would not allow me to create a plugin without first installing Rhino 6 - to which I do not have a license for (I needed a 64-bit .exe). Is there a way around that?

I see, I never noticed that because I do have Rhino 6 installed as well.