Rhinocommon.dll couldn't find in Rhino6 Mac

Hi everyone,

I was working a plugin project on the Windows system, and when I try to clone and open repository in Visual Studio on my Mac system. Expected outcome happened, .dll directories changed.
Screen Shot 2020-02-19 at 10.02.31

When I try to browse and add .dll files, I couldn’t find .dlls in the Rhino6 package as well as Windows version.

How can I add .dll files to my project that created before Windows OS?
What is the mistake of mine?


*.dll are Windows specific and don"t work on OSX(without workarounds). Have you tried creating a new project on the mac to look up all the references first, and change accordingly?

Hi @rgr,

Thanks for your answer. I tried what you said before.
The files which coming from Windows named as Resources but in MacOS named as Dependencies.
Now, I found the solution, I am adding images here in case of someone encounter with same issue.

This isn’t quite true in the context of Rhino on Mac. Rhino embeds the mono runtime which can load .NET based DLLs (assemblies).

@curtisw, do we have a good set up for helping with cross compiling projects like this?

The best way would ideally be to change our templates on windows to use the NuGet Packages instead of referencing the installed assemblies directly, or at least have that option. This should work for both Mac and Windows.

I do have dotnet templates that we could upload to nuget.org so people could use dotnet new to create projects as well, but the above would be more ideal.

1 Like

Hi @curtisw,
I will try both option with seperated sample projects immediately.
Thanks in advance!