Rhinoceros 7.1.20343.09491 silent install fails after release of newer version

I’ve created a silent install of Rhinoceros 7.1.20343.09491 for installation using Microsoft Configuration Manager.

rhino_en-us_7.1.20343.09491.exe -package -quiet -norestart ENABLE_AUTOMATIC_UPDATES=0 LICENSE_METHOD=ZOO ZOO_SERVER=xxx.yyy.zzz SEND_STATISTICS=0 CUSTOMER_NAME=xxxx COMPANY_NAME=xxxx

This no longer works as an ‘Update Available’ window appears and the installation pauses waiting for me to confirm or deny installing the updated version.

My belief was that ENABLE_AUTOMATIC_UPDATES=0 would block the installer checking for upgrades. Adding DISABLE_INTERNET_ACCESS=0 to the command line does not help.

How do I disable the check for updates?


Oh no! This is probably a side-effect of me fixing (WWW-1393 Installer feeds failing) combined with a bug that never showed up in Rhino before, because this bug was broken for so long.

I just logged: (RH-63356 Rhino Installer blocks while asking to update)

I think it’ll be possible for me to fix this in a future Rhino, as well as update my fix to WWW-1393 to only return update notifications when newer Rhinos are installing.

As a side note, I recommend you install keep up-to-date, and install 7.4, as we’re fixing lots of bugs that were in Rhino 7’s initial releases. For a long list, see Rhino 7 Service Release Available.

Thank you for an amazingly swift reply. I’ll be keeping an eye on the release page.

@dennis.landsem I just reverted my fix for WWW-1393 - you should no longer be seeing update notices when installing Rhino 7. Can you please verify that’s true?

I can confirm that I was now able to carry out a silent install of Rhinoceros 7.1

1 Like