Rhinocam2 in Rhino4 wont install. Non unicode MFC plugin?

Hi I try to install rhinocam2 in rhino4, but it wont go all the way.
I bought Visual mill basic in 2004. In 2005 upgraded VMill to Rhinocam1pro and Rhino3.
In 2007 upgrade to rhinocam1 to run in rhino4
in 2008 upgrade to Rhinocam2 for rhino4… If I remember right.
Every upgrade came with a code .
I had it working on that laptop since 2011 Every thing was woking fine
Untill I try to install it in a new computer, it will install up to Rhinocam1 in Rhino3 only

This is what I got when I try
Any body had this before or knowabout

412](upload://bWXDo0JGewwC5J7wwy6cNa2CeTs.jpeg)

The image above still looks like Rhino V3… Are you sure RhinoCAM 2 is trying to install in Rhino 4? I remember there were quite a few problems with wrong directory installs back then. I assume this is Windows 7?

If you don’t need Rhino 3, maybe uninstall that and remove all the traces, then try to install RhinoCAM 2 in Rhino 4 (check all the directories as well, RhinoCAM had a tendency to create its own if it didn’t find the directory it was looking for).

I don’t know if Mecsoft supports RhinoCAM 2 anymore, but you might also contact them.

Thank you for the quick response . Yes it is win 7 . I will try to uninstall Rhino3 like you said. Mecsoft gave it a try , generate a new code but that did not work . Suggested I buy a new version. I also try the dongle company they say it is the software company’s problem.
I will post after I try to remove Rhino3

I tried but Rhino4 wont install without rhino3. Like rhinocam wont install without visual mill.
Rhinocam work in rhino3 but not in rhino4

Rhinocam2 wont install in rhino4 need rhinocam1 install
I am dizzy

I will post rhinocam forum Thank you again
Normand

All you need is the CD key for Rhino 3 to install the Rhino 4 upgrade version, you do not need to actually install the software.

And you shouldn’t need to install RhinoCAM 1.0 in order to install RhinoCAM 2. The license is in the dongle, if you were running RhinoCAM 2 before the mishap, it should still be valid, you shouldn’t need to upgrade it or anything - the dongle knows it’s licensed for RhinoCAM 2, and won’t run RhinoCAM 1 by consequence.

However, one thing to check is that the latest dongle drivers are installed - the company (Sentinel) has changed several times, it’s now Gemalto. https://sentinelcustomer.gemalto.com/sentineldownloads/

Other than that, the programs are old enough that you are not likely to get much support, so your best hope is that Mecsoft can fix it - or offer you some decent deal to update (however, you would need to upgrade to Rhino 6 in that case as well).

Thank you , I have reinstall the driver for the dongle also.
Rhinocam2 in rhino4 work but in demo only.
And work demo only in my old computer now .I cannot save or pp anymore, That why I think the dongle is the problem ,
I remember you have to unplug the dongle for registering at some point . That is where I notice that it did not work anymore,I think I unplug at the wrong time.
Thank for the link. I have found a forum on that site . But you have to be Mecsoft or an employee to post . They have a trouble shooting software to analyse the dongle . It is my next step . I tough I post here first because of the ‘‘non unicode mfc plugin’’ message.
Last time I install it, in 2011 there was something with unicode .
I would rather pay for it to work than a new version . For what I am doing this cadcam
is super great . Even if it is 10 year old . . .
I will let you know how it turn out
Normand

.

The Mecsoft user forum should be open to all people who purchased RhinoCAM no matter the age. They have changed the platform/format several times, so you probably need to create a new login.

https://mecsoft.com/phpbb/index.php

Most likely. Somehow the license in the dongle got corrupted. Unfortunately I think only Mecsoft can fix that one - if they are willing.

Hi Helvetosaur
What I mean ‘‘But you have to be Mecsoft or an employee to post’’ was to post on that forum https://sentineldiscussion.gemalto.com/search/dongle%20fail .The dongle forum.
Sorry for the confusion . Mecsoft told me they dont deal with dongle anymore.
The dongle Gelmato said that they dont deal with these specific dongle anymore.

I dont know much about computer, it take me time to research. I also would not want to kill the dongle totally . I can still do stuff the way it is .
I will try again to reinstall the software
Normand

I might be missing a patch to get visual mill 5 to open in rhino4.
I am waiting for a response from Mecsoft.
https://www.mecsoft.com/phpbb/viewtopic.php?f=6&t=731

I have a email that I printed that say to open the file with the code that I received in 2007

Problem solved . After looking at mecsoft forum I realised that they did send me that file in 2007 . I found it in an old backup cd.
Maybe I am the only one using this old version ,it is fine by me
Thank you

1 Like