RhinoCam toolpath for guitar neck

Hello, I’m a little confused. I have a wood with a length of 900x72x65mm that was previously thickened for the model to be milled. When I try to generate the toolpath, I do not know how I can control the depth of the milling machine in detail, without wasting much time.

Thank you



No one knows?

Did you try creating a closed curve as a region? Keep the distance less than the radius of the tool and the tool won’t drop down the sides.

You could also add some surfaces under the part surfaces that don’t allow the tool to go down the sides. But personally I would use a closed curve to control this if it was me.

Does this help?

Hi, hmm I don’t know how to do this :slight_smile:

You may need to look at some tutorials on creating limiting regions then. In pretty much all RhinoCAM 3D operations, you have a “Regions” tab where you can choose one or more closed regions to limit the toolpath to. Create your curve beforehand with Rhino tools - can be anything a closed polyline, circle, freeform curve etc. - then start the Mop, go to the regions tab and select the curve. Then fill in the rest of the operation parameters and generate…

Thank you very much, I will try it.

In the illustrations above I just used a simple rectangle. It’s quite easy to do as Mitch explained, but knowing how to do this is vital to success with RhinoCAM, or any CAM program.

Hello, I tried this option but, the problem is this: if I do not activate “step-down Z cuts” everything goes perfectly, but I do not have control of the milling cutter in the material, when I activate “step-down Z cuts” the mill begins to cut the material regardless of region.


Can you post a sample file with the toolpaths - difficult to see exactly what’s happening from the images.

In general though, a parallel finishing toolpath is just that - one pass (no step-down) over the area after a previous roughing toolpath has removed most of the material.

From what I could see in the video, looks like all the ops stayed within the region boundary. Maybe I don’t understand what the problem is then. Are you saying the Z levels are not cut in the right order?

As I said, normally I run a roughing pass first, then a finishing pass without step down.

I want the Z level to start from the created region, not from the material level, because it was previously cut.

Ah. Look in the same Z-Containment dialog just above where you set the Z steps. There you can set a max Z and a min Z to limit the operation. You should set the max Z to the height of your region (or whatever you want).

In general a region’s Z level is not considered for limiting operations - only its projection in XY. Regions can be anywhere in Z and still limit the toolpath in the same way. It’s like looking through a window onto the part.

1 Like

I already tried, it doesn’t work. One possible solution would be this (the movie). But there is definitely a professional option.

  1. Which version of rhinocam are you running?

  2. If I was doing this, I’d do separate roughing and finishing operations.

Use horizontal roughing first, leaving about .05” of stock. Use a roughing bit or a straight upcut for that.

Then use the ballnose to finish it. And you probably want to use only climb cuts on the finish, and pay attention to grain direction. If you go back and forth, you’ll get much more tearout.

It does, but perhaps not the way you are expecting it to. Stepdowns are always horizontal to the machining plane, not offsets to the toolpath itself (which is what it looks like what you want). In the Pro version you can instance toolpaths in Z, or as you showed, even with the Standard version, copy the operation one or more times and set a stock to leave.

I still don’t know why this is needed though, the most often used procedure is a rough which removes most of the material, followed by a finish path. Often if I want to level off the large steps left from the roughing operation, I use a “semi-finish” pass in between, which is essentially the same operation as the finish pass, but with a small stock to leave (like 1mm) and a larger stepover. That flattens out the steps and leaves a more or less uniform material thickness for the finish pass.

1 Like

There’s also re-roughing in the pro version, which I use a lot to save time. I hog out most of the material with ½” stepovers and cut levels, and then use the re-roughing function to go back and do ⅛”-¼” steps, set to leave .05” stock. This gets pretty good results with the final finish, even in pine and other woods prone to tearout.

But again, choosing the right direction for finishing passes matters. And what direction to go and whether to climb or conventionally cut differs based on wood species and grain orientation.

Also: I cannot emphasize this enough: MecSoft’s annual tech support subscription program is worth every penny. Uday, Don and Krish will walk you through anything that confuses you, Monday through Friday, 9-5 Pacific time. And they’ll do more than just tell you what functions to use and how. They’ll troubleshoot, help you write custom posts. They’re awesome.

1 Like

I could not agree more with this statement. I deal with a few CAM products and MecSoft has the best support by far.