Linetypes: inaccurate, irregular, weird, incorrect, error

Hello,

I’m having these weird linetype problems. They don’t show correctly in the modelspace, paperspace and even when i print them to pdf. Some look good, other don’t. as shown in the image below.

I tried to recreate this problem in a seperate file and tested if it happens to other rhino versions as well. Unfortunately it did

So i’m wondering. Is this normal for Rhino or is there something wrong with my settings or PC.

I attached the rhino files

Linetype error R5.3dm (45.4 KB) Linetype error R7.3dm (67.9 KB) Linetype error R6.3dm (60.3 KB)

Thanks!

Can you run SystemInfo in Rhino 6 or 7 and copy/paste the results here ?

1 Like

Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ed629035202f07e8b84a3ee211479ca20bb81b73)
License type: Commercial, build 2021-03-08
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\6.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\export_PDF.rhp “PDF Export” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Same thing happening here on the MAC. Tried 2 scales: 1x & 1000x both with tolerance 0.0001m


systeminfo.txt (11.2 KB)

Hello - if the curve is composed of multiple joined sub curves, you can try LinetypeDisplay and set that to usse ‘PatternBySegment=No’ - does that help?

-Pascal

These are single nurbscurves. For testing, I did rebuild them into polylines and changed it to ‘PatternBySegment=No’. But it didn’t make any difference.

I did noticed the following:
Once i change the linetype scale from 200 to 1000, the linetype viewed correctly. See image below

Also printing the layout to PDF.
Above: linetype scale 200
Below: linetype scale 1000

I have a feeling that once a curve gets TOO long with a relative small pattern (for instance when a curve has many many dashes) Rhino seem to struggle to preview the pattern.

@pascal
Do you have any thoughts on why rhino can’t preview and print these linetypes correctly? many thanks!