rhino5 surface "sweep 1 rail" "unable to order shapes on rails"


I have tried hard to follow a youtube example of creating a screw thread on a cylinder. I get stuck when I try to sweep a D shape after I add this D shape oriented perpendicular to a helix aound the cylinder. The youtube makes it look so easy but I must have tried to do this so many times only succeeding once when the D was at the wrong orientation - and then not being able to repeat even this. Very frustrating!


Hi Rupert - please post the curves…


Hi Pascal

Here is the youtube video I was trying to follow.

I skipped the bit where the helix is extended in towards the center of the cyclinder and then scaled up as I thought this may have cause the sweep to fail. But it fails anyway.

I dont know how to paste the curves to this message but am following as closely as possible the video.

Making screw threads which I can print in 3D would be brilliant if I can succeed.


Hi Pascal
I used a circle instead of the D shape and it worked immediately. So I am not sure why the D shape failed.
I think I can get same result if I trim the part of the sweept circle that falls inside the cyclinder. Please what is best way to do that?
I dont know why the vide used a D shape. Perhaps that fails because the maths gets too complex.