Rhino vs macOS sierra / CRASH

@vaz what was the settings you changed?

This worked for me as well. Changed from ‘iMac’ to ‘Display’ under the color tab, and Rhino starts up fine.
Here’s the screenshot

Same here - if I swap from my calibrated profile to standard “iMac” I can get Rhino to open…swap it back and we crash again…

Non-worker on left, worker on right:

…and Sorry for the delay Dan, but the preferences thing definitely made no difference as a above, so I’m just going to experiment a bit more with the colorsync profiles…

Fresh user on system Rhino OK. (New user has “iMac” profile as default). Switch to use my calibrated profile stolen from my normal user account and Rhino upset again…

1 Like

Thanks for digging into this @philw! Much appreciated.

We are continuing to work on this issue. We do not yet know exactly what is causing the crash, but we are getting closer. We believe this is related to support the “improved support” for extended-range pixel formats and wide-gamut color spaces that are found on the newer iMac 5k displays. It is possible this is something that Apple needs to fix, but we may be able to work around it (if we can reproduce it) now that we can reproduce it on our new(ish) iMac 5k.

@philw Can I please get a copy of your calibrated color profile that is causing the crash? We are working get our hands on a 5k iMac where this crash is occurring, but we will need a color profile that is causing the crash to reproduce it (the default does not seem to crash). I believe you can export these profiles using the ColorSync utility.

In the meantime, for users that are experiencing the crash (likely on a 5k iMac), please change your color profile (System Preferences > Display > Color) to the Standard iMac Apple RGB profile for the time being.

It is worth noting that Apple has just released a public beta of macOS Sierra 10.12.1. It is possible this issue is fixed in that release and we would greatly appreciate anyone who is experiencing this issue and can reliable reproduce it, to test this out on the 10.12.1 beta.

It’s great to have so much capable help chasing down this issue.

Y’all are awesome,

I’ll email it to you Dan. Just did another test - I had another profile generated at the same time with the same profiling software/hardware for a second display I had hooked up at the time and Rhino was Ok with that as my profile as well. I’ve included both for you.

1 Like

Don’t know from what, but he set the monitor profile to LCD Color

We were talking about that on the Italian Discourse:

Another update on this issue. Upon installing the macOS 10.12.1 beta on our iMac 5k machine (which was suffering from this crash), it seems that Apple has fixed this issue. So, this bug was not our fault.

Thanks again to all who have provided information to help us identify and diagnose this problem. In the meantime, I’ll repeat what I said above: please change your color profile until Apple releases a public update to macOS Sierra.

Sorry for the delay…I changed monitor setting color from CIE RGB to LCD color

Hi all,

After facing the same issues changing the color profile on my iMac solved the problem. Until macOS 10.21.1 goes live I’ll stick to this fix. Many thanks to @dan, @philw, @vaz, and, and…

Here are the details:

Software information

Software versions
Rhinoceros version: 5.2.2 (5C256)
IronPython version: 5.1.2015.131
Language: en-ET (MacOS default)
OS X version: Version 10.12 (Build 16A323)


Third party kernel extensions
com.globaldelight.driver.Boom2Device (1.1) 73CE7A76-3526-347C-98FD-5B794ABB870D
com.github.osxfuse.filesystems.osxfusefs (2.8.1) 81CD1167-54E2-3435-9EAE-483FC36ABF1F

Hardware information

Computer hardware
Hardware model: iMac17,1
Processor: Intel Core i7-6700K CPU @ 4.00GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon R9 M395X 4096 MB
Memory: 4096 MB
Screen size: 2560 x 1440
Displays: iMac (217dpi 2x)

USB devices
Western Digital: My Passport 0820
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Broadcom: Magic Keyboard
Broadcom: Magic Trackpad 2

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.44.68
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 8x
Mip map filtering: None
Anisotropic filtering: None

We have added a work-around for macOS Sierra 10.12 (even though this bug is fixed in 10.12.1, currently in beta) in the latest RhinoWIP (5D92w). You should be able to use color profiles with wide color gamuts again. Please let us know if it is not working as expected

1 Like


I’ve tried the RhinoWIP (5D92w) very very briefly.
I hasten to inform you that the crash issue seems to be solved.
I can open files and view objects.


1 Like

Mine is crashing too with the OS 10.12 update. ugh.

Rhino is crashing on macOS Sierra, when “Display have separate spaces” is disabled and Rhino is starting on secondary monitor

I’m afraid I’m unable to reproduce this issue on my computer (Retina MacBook Pro, macOS Sierra 10.12 with secondary display). Can you provide more information about how to reproduce the crash?


5.2.3 seems to fix the issue.

1 Like

@dan Similar issues have been reported in SB