Rhino user working in Sketchup office


#1

So far this has been a nightmare experience for me.
I have been creating large scale architectural models and exporting them using the .skp exporter in Rhino.
When I open the Sketchup file all of the objects are exploded. The geometry is very clean, no triangulated faces but the objects are all separated into faces and edges and are not able to be joined back together.

I’ve also tried .3DS format export which makes jagged, triangulated geometry ( not good)

If someone on here works in a similar environment and has some tips for a workaround PLEASE share… I am about to have to find a new job because of this problem.


#2

what about exporting obj format?


#3

I typically work the other way around, fixing or rebuilding SKP models in Rhino.

Unfortunately I don’t know of any translators for Rhino to SKP other than the native Rhino export. Have you tried toggling the export options in Rhino?

You may find that 3DS Max to SKP works better, in which case you could try something like NPower translators for Rhino to Max and then from Max to SKP. A long and expensive way round though.

Why are you building your models in Rhino and not natively in SKP if they need to be imported there?


#4

Im designing complex structures in grasshopper / using geometry that has lofted curves etc… geometry that I don’t think sketchup can make.
If rhino exports to SKP I shouldn’t have to work in SKP. just export… right?


#5

Hi. You might also try Spaceclaim as a Trial version and see if it can do what you need.:
http://www.spaceclaim.com/en/trial.aspx
Spaceclaim can directly open and save both Rhino and Sketchup files so maybe you can open the .3DM file with Spaceclaim and then save it out into Sketchup format.
I’m not sure what the restrictions of the trial version are though.


#6

Quite right.

Perhaps there is some limitation to the complexity that SKP can represent. Do you get the same discrepancy on simple primitives?

I think that the current SKP import/export is only running up to version 8 of SketchUp, perhaps it is time for a tune up.


#7

There are an endless supply of free Ruby plugins for Sketchup. I’d do a search for ‘weld sketchup plugin’ or other similar terms. I’d be surprised if you don’t find a plugin that would merge or weld vertices that share a common location.


(Bob McNeel) #8

@tim, can you help with this?


#9

http://extensions.sketchup.com/en/content/weld

I don’t know if there is a limitation of size or amount of geometry but I just created a box in Rhino, saved it as a SketchUp file. Opened it in SketchUp and verified that all the faces are independent polygons. I selected the box, ran Weld and all the faces are now connected.


(Scott Davidson) #10

Do you have an example Rhino model you can send this way? I normally see problems that are simply break angle welding in Sketchup. Perhaps a model with a few of the objects that are causing trouble and a few of the objects surrounding them that are correct?

Which version of Sketchup are you using?

We are testing it here and have not found a time the faces some in separate.


#11

Interesting. I just made a box in Rhino. Saved it as SketchUp file. Opened it in Sketchup - 6 separate polygons. Closed the file, didn’t Save. Opened it again. 6 connected polygons. Something’s a bit screwy. I’ll try it again.


#12

Test3 - all faces separate


(Scott Davidson) #13

Could you save the 3dm and the SKP file you are saving? I have not been able to get the exploded faces in my attempts. Also, are you exporting as closed polygons from Rhino using the SKP options?

What version of Sketchup are you using? I am using 14.1.1282 (Help pulldown > About Sketchup…)


#14

SketchUp 14.1.1282
Export Planar Regions as Polygons is selected.


#15

test box for sketchup.3dm (20.4 KB)

SKP isn’t one of the file upload options so I can’t send that along


#16

YES!! Exactly what was happening when I tried this… I thought I was going crazy. Could not figure out why the program was behaving this way.


(Scott Davidson) #17

You can send the SKP file to me directly: scottd@mcneel.com

The behavior sounds bizarre. Is it the first thing you import into and empty model? Or do you use the Import command into an existing model? Does it makes a difference?

Thank you.


(Scott Davidson) #18

I try to open the 3DM model in Rhino and it seems empty. Is it a Grasshopper box or a Rhino box?


#19

By far the easiest and cleanest way to go from rhino to sketchup is through MOI. (Moi3d.com) there’s a 30 day trial you can use, or its only a couple of hundred to buy anyway.

Select the stuff in rhino you want to go to sketchup, copy it, paste it into an open session of moi, and then save out of moi as sketchup.

Moi can also read and write rhino files since it uses the .3dm format as its native file type.

Hope you can keep your job!

Cheers
rabbit


#20

Sorry, I dropped the ball on that.
I just sent you a Rhino file that was exported as a SketchUp file, and the SketchUp file that exhibits the behavior being discussed.