Rhino to Sketchup - Crazy Shapes

sketchup
export

(Thais Zuchetti) #1

Hello everyone!
I always like to work with Rhino although my co-workers prefer using Sketchup.
Many times when I try to export something from Rhino to Sketchup the surfaces of the solids end up like crazy and it’s very hard to keep editing the shape on Sketchup.
This is my situation at the moment: I made this image sampler mapping with grasshopper on a panel

I tried to export to sketchup following some tutorials already, exporting in dxf as 2004 lines, transforming Surfaces in Meshes and Meshes in Meshes but it ends up like that:

Is there any way I can export this thing smoother? without these crazy lines around something like that??

(in this image I hid Edges view on Sketchup, it’s not effective while trying to edit the shape because all lines are still there, but hidden)

Thank you all :slight_smile:


#2

try exporting if from Rhino as .SKP
(there’s a SketchUp exporter built into Rhino)

when exporting, use the option – ‘Export planar regions as polygons’ …then all those lines won’t be there in SketchUp. (assuming that’s a flat plane in your model)


(Thais Zuchetti) #3

Hey!
Thanks for the fast reply!

Actually, this happens (somehow the lines are still there but not as lines)

I would like to know if there’s an option to export Rhino to Sketchup on a way the drawing is 100% as if it was made on sketchup from the beginning.

On Rhino what I did was I created a Plane and Extruded it. Did the map drawing on Grasshopper and used MakeHole command to perforate the panel I had. Am I missing something?!


#4

hmm… i don’t know then…
it works fine for me following these steps:

in Rhino, have the outer rectangle and circles as curves (shown in the middle in the image below)… select all of that then ExtrudeCrv to make the solid:


_Export the volume from Rhino to SketchUp format with these settings:


open the .skp in Sketchup :


there are no hidden lines etc on the top face… for example, i can click anywhere on the top surface to select it then delete it as a single surface :

??


#5

This is not a Rhino5 problem, problem arises when you cut holes in your mesh.
These (crazy lines) are the mesh connections, which form polygonal mesh.

In Rhino5 you work with nurbs surfaces, Sketchup support only meshes.
If you do not want to have these big triangles, play with meshing parameters

https://wiki.mcneel.com/rhino/meshfaqdetails


#6

SketchUp supports Ngons though…

so if the mesh is planar, it doesn’t have to have all those lines.


#7

Aha, ok, thanks for info, I am SketchDown :flushed:


(Thais Zuchetti) #8

ooh thanks guys a lot!
I always thought what it could be! I’m trying things here but all information given was already very handy!


#9

What I would do is export to sketchup via MOI - MOI has a far better sketchup exporter than rhino, and its no drama since you just copy and paste your stuff into MOI direct from rhino, then export…

cheers
rabbit


#10

That looks more like z-fighting - do you have more than one surface in that model?

I’d check to see if you’ve got some wry exported surface.

Try exploding the rhino model SelDup and delete anything that is highlighted - then Join everything. From that run ShrinkTrimmedSrf and then try exporting it.

Andy


(Thais Zuchetti) #11

hehehehehe turns out that there was another surface on the surface!
Thank you very much! Very observer :slight_smile: