Rhino Texture Bake Resolution Cap Bug

Hi Everyone,
context : So I’m working a piece that has a texture that is quite large (around 9 feet tall), and the surface that image is mapped onto is cyllindrically / conically shaped, I have been able to unroll it successfully by using the Bake command, then Squish.
problem : when I bake it, it only takes up less than a quarter of the resolution of the texture and puts it in the corner which means that if I bake at 8K which resolution is capped at for some reason, it is effectively 2K making it 19 pixels/inch which is an unacceptable resolution.
solutions I tried

  1. I tried baking in blender which has no resolution cap for baking, then using the UV editor to reposition the texture coordinates so that it maps correctly in rhino however then it becomes a “custom mapped object” and won’t squish properly
  2. using that hires bake from blender, I tried overlaying that image on the original bake in photoshop, then cutting the canvas in half - then changing the UV repeat and offset settings in rhino to make it look just like the original - however this doesn’t work becauce for some reason when you change the UV repeat settings on the squished polysurf it gets rid of the mapping!
  3. this solution works but poorly, by overlaying on the original bake at double resolution (16K, effectively 4K) and not cropping it, it is able to squish however it means 3/4 of the texture is wasted but I really would like it to take up the whole 16K texture

let me know if anyone has any ideas, thanks so so much :slight_smile: -Z

Hi Zane - can you post a file, with the texture, or send to tech@mcneel.com, with a lick back to thios topic in your comments?