Rhino Render black screen - Cycles CUDA problem

Clean driver install done with no results. Any further ideas? The same happens when I switch to integrated GPU. I am clueless…

That’s a very old laptop.
It’s time to consider replacing it.
It probably worked fine for V5.

Nvidia quit updating driver for it 2 years ago.

Well I didn’t won’t to hear this type of answer… Rhino 7 was just working fine on this laptop. Slower, but properly. There has to be something else.

Which version of rhino was the latest that seemed to work OK?

It worked, then it stopped (and I guess that there was only the update in between) and I got one other update, assuming that it will solve the issue. So that was two updates ago.

Sounds like when it was working you were using either the last or next-to-last version of 7.4. Can you reinstall that version to see if it starts working again?

THE GPU DRIVER HASN’T BEEN UPDATED IN 2 YEARS! Windows updates come fast and furious, and any one of them could render it permanently unusable. You are running on borrowed time.

As I said before…for 20 years people complained that Rhino didn’t take full advantage of advanced graphics hardware, but they didn’t seem to realize there would be a cost to that, and the cost is you can’t run it on a potato anymore! The minimum recommended specs are a 4GB GPU.

1 Like

C’mon… I know that my laptop is older one. I was not asking for unwanted advices to go buy a new machine :wink: please. I noted that it was just working fine and now it isn’t and obviously everything else works fine on my nice old laptop. There are already people in this thread who pointed out some useful advices and I am glad for that.

I would love to, but after a while of googling I have to ask, where to download older 7.x versions? I only found Rh6 and older…

EDIT: I found out that when I purge all materials, save and restart Rhino, render just works. As soon as I assign any material, it stops working. Also, when I purge materials without restarting, it won’t work againg.

At some point support for the Kepler architecture will be dropped, it is the oldest architecture still supported, but at some point we’ll be upgrading the CUDA kernel compiling tools to a newer version. The current toolset tells me that Kepler is obsolete and support for it in future toolsets will be removed. I don’t know yet when I will be moving to the newer toolset, that depends a bit on upstream Cycles requirements - right now you’re still ‘safe’.

If you want to keep using Raytraced/Rhino Render in v7 I suggest changing to the CPU as render device. You can change that via Tools >> Options >> Cycles.

1 Like

This is something that @brian should be able to help you with if that’s the route you want to follow.

I have the 750 in my mac running Windows 10 and I chose to use Raytraced on the CPU (i7) on that machine since it was faster. Just so you know before you waste too much time on bugtracking that old card.

1 Like

Switching for CPU works… GPU black. Thanks for suggestion :slight_smile:

1 Like

Same problem here Switching from GPU to CPU didn’t do it.
image

Changing the renderer to legacy rhino renderer (the old renderer i think?) solved the problem in my case.

System Info:

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 7.6Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 1-21-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
- Windows Main Display attached to adapter port #2
Primary OpenGL: NVIDIA Quadro K2100M (NVidia) Memory: 2GB, Driver date: 7-1-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 425.91
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-1-2019
Driver Version: 25.21.14.2591
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

@nathanletwory
Nvidia K1200 4GB with latest driver 461.92
I have a similar problem, in Physically Based Material in Bump slot with Normal Map.

That is fixed in latest 7.5 Service Release Candidate.

@nathanletwory
JesterKing,
thanks for answer, but i thinkSRC installed here is the latest 7.5.21068.13001 ?
regards

You’re 14 days behind:

Oh god you are right, sorry :+1:

Bonjour, sur mon PC toujours le problème!

Une idée?

RhinoV7 SR7.5.2108-Capture d’écran 2021-03-28 084942

Merci d’avance