Rhino is freezing

Bug in service release candidate 6.17.19211.14112, 2019-07-30 (wasn’t there in the last WIP). Rhino freezes in almost every session (spinning beach ball) and force quit is the only way out. I can not repeat it at will so this is quite annoying. It can happen after clicking (selecting) a line or clicking a layer or whatever. I can’t think of any pattern at all that would cause the freeze - it seems to be totally random after working for a while with a file. It often appears to be happening in a maximised (right) viewport though - I think…

I can send the file I have been working with lately (directly to McNeel).


Hi Philip - thanks, I am downloading your file.

Yeah… don’t heart me up too quickly - I have not reproduced the problem… I don’t suppose you get the crash dump interface at any point from this, do you?

Just fyi, it’s not just me - we had three techs working with your file… no one ran into any problems thus far.


1 Like

Hi @pascal and @BrianJ… It’s happening again today in the latest SR-candidate. It’s impossible to figure out why - no clear pattern at all. It has happened (only) twice today. The first time I was making a simple circle and the second time I barely touched the scroll wheel (???)… Fortunately it doesn’t happen often - but that also makes it hard to reproduce. You have to work with the file a looong time…

It’s frustrating because this is new for the release candidates - in the betas this never happened! Scary…
I wonder what changes have been made that could cause this… and no, I unfortunately don’t get any crash dumps.

I don’t know if it has anything to do with the problem, but I have noticed another strange behaviour with the ‘distance’ command and the cursor tool tips. After picking the first point I sometimes don’t get any read-out for the second point at all. It usually works normally - but not always (this one is also hard to reproduce).

I don’t know what to do. I’m just hoping that you eventually can figure it out… Let me know if you want me to test something specific on my machine.


Hi Philip - thanks for the details - this does sound like a frustrating thing to deal with. My guess of the moment is that it is likely video/display related but I’m just wild-guessing. Can you run SystemInfo and copy/paste the results here?


I did send the system info earlier to @BrianJ :grinning:, but here it is anyway:

iMac Pro.txt (2.8 KB)

This is supposed to be a nice machine with a reasonably good GPU - at least it was damn expensive when I bought it :pensive:


Hi Philip Yeah, I believe it… since you’ve been running (I think) into a series of problems that we cannot reproduce here I just wanted to see if we have something similar around to test on. I’ll ask.


1 Like

Here is a video of the second problem (but as I said, I don’t know if it has anything to do with the freezing).


Hi Philip - thanks, I’ll see if I can make that happen - is that (I’m guessing yes) more predictable?

@Philip - am I correct that you do not get any crash report UI when you need to force-quit?

Also, @Philip it looks like you have Iris installed - have you tried working without that? Can you uninstall or disable it temporarily?


Hi Pascal

Yes it is - but not always…

Yes, that’s correct - no crash report UI, even if I get the message “Rhino has crashed…” and a promise about displaying the crash report UI in a moment, but nothing pops up.

I can try disabling it. I haven’t used Iris in a long time anyway - sorry to say it has newer given me any result I could use. Iris would need a lot of love to be useful, but that’s another story…


Same problem here with the service release candidate. Downgrade to Rhino6 solved the problem.

Is there any chance this is computer heat related?

No I don’t think so. The cooling fans never even start spinning when working in Rhino - or any other program for that matter (at least I can’t hear them).


I only mention it based on the circumstances you report and the inability of us to repeat it.
If you can effect an improvement in cooling; perhaps make sure you don’t have a build up of dust and maybe direct an external fan into the ducts, it would be interesting to see if anything changes.

I don’t think it has anything to do with dust or heat. This machine is only 1 year old and should be quite dust free, I think.

Edit: The spinning beach ball is also new to the SR:s, as I mentioned - the betas didn’t have this problem.


The bottom line is until we can reproduce the problem here, we can’t fix it.
All I’m asking is to try to make small changes to try to isolate the problem so it can be found.

1 Like

@John_Brock We could probably give Philip a list of older builds to see when the problem started. I’m not sure what we can do beyond that since we are having trouble repeating the issue.

I know, I know…

I did what Pascal suggested… I disabled Iris. I just haven’t done so much modelling after that (been busy with other things), so the problem is perhaps fixed already. I also uninstalled Duet display - another program I installed last year and never used.
Next week I have some modelling to do, so let’s see. I’ll let you know if I run into the same problems again.

Thanks for your help and testing so far!


Well, it just happened again… This time I didn’t do any modelling in Rhino at all. I opened Rhino, Mail and Safari (in that order) and full-screened all programs. I read my emails, spent some time in Safari on different sites for a couple of hours. I then switched to Mail (sweeping left with tree fingers on the track pad or two fingers on the Magic Mouse, to be exact) - and then switching to Rhino (again sweeping)… I tried to close Rhino with cmd + Q (decided I first wanted to update OS X to a the newest version) -> beachball! Had to force quit again.


@Philip I’ve been struggling to reproduce this as others have. Can you please run ExportPreferences and post them here?

Another consideration is whether or not this happens in 6.16 (the initial commercial release). If not, this would point to a regression in 6.17. If you are willing to test on 6.16 - and I know this is a hard one to “test” - that might give a clue.

Hi Dan

Here’s the plist-file:

ExPrefs.plist (373.8 KB)

I’m not sure… I think I “upgraded” to the SR candidate immediately, so I didn’t really model in 6.16 at all.

Sure - where can I get it?

It shouldn’t be too hard to see if 6.16 is ok or not - if everything is working normally after a couple of days of modelling in 6.16, then it’s a regression in 6.17. To discover what’s actually ‘wrong’ with 6.17 is perhaps much more difficult, I guess…?