Rhino.Inside.Revit / Set Parameter Value

Hi Rhino Community,

I’m new to Rhino Inside. I’m trying to export a GH Exoskeleton definition into Revit. The ExS is made of Circular Hollow Section (CHS). My aim is to be able to control parametrically the diameter and thickness parameter of the tube within Rhino.Inside. Here is what I tried:

  1. Set a Revit Family consisting in a CHS for my ExS members. My parameters are D for the external diameter and tw for the wall thickness. I’ve set abitrary values for D and tw.

  1. Brought this family into GH definition and applied to the my geometry using the Add Beam component.
  2. Attempted to use the Set Parameters component to modify D and tw but it seems they’re not recognized as parameters. I’ve got the following error message “Parameter D is not defined in Element”.

image

Any idea why the Set or Get Parameter doesn’t work in that instance? Is there maybe a better way of doing it.

Thanks for the help.

It looks like you are trying to modify type parameters, you would need to make those instance parameters or modify the type parameter.

@Rickson,

Thank you for your feedback. That makes sense. I’ll try it.
Beside that, do you know whether it is actually possible to modify the type parameter directly?

yes, put your List Item component with the Type into the Set Parameter and it should work.

@Rickson,

I’ve tried it and the issue is the same. However, if I tried to query a category parameter such as length, I can access the element values. I believe there is something wrong with the definition of my family parameters “D” and “tw” but I cannot see what.

use the Element Parameter component on the Type to insure you are getting the proper Parameter for D & tw.