Rhino frozen when trying to adjust "length factor" in annotation style

Even moving the cursor into the field “length factor” without adjusting the value could cause Rhino to freeze completely.

May I ask if anyone has encountered similar issue?

Hi -

I haven’t heard of this.
Please post your SystemInfo result.
-wim

Thanks, @wim

As suggested, I’m posting my SystemInfo below, before I do the stuff which causes Rhino to freeze.

Rhino 7 SR13 2021-12-14 (Rhino 7, 7.13.21348.13001, Git hash:master @ 7696723f74a63695b3c372a89110c0ca8c78b890)
License type: Commercial, build 2021-12-14
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 1.3e+02Gb)

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA Quadro RTX 4000 (NVidia) Memory: 8GB, Driver date: 7-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.41
    > Accelerated graphics device with 4 adapter port(s)
        - Secondary monitor attached to adapter port #0
        - Windows Main Display attached to adapter port #1

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  
  Anti-alias mode: 8x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 7-12-2021
  Driver Version: 30.0.14.7141
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
  C:\Users\USERNAME\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\SpeckleConnectorRhino.rhp	"SpeckleRhino2"	2.1.26.6073
  C:\Users\USERNAME\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp	"ElefrontProperties"	1.0.0.0

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7\Plug-ins\Commands.rhp	"Commands"	7.13.21348.13001
  C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp	"WebBrowser"	
  C:\Program Files\Rhino 7\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp	"IdleProcessor"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.13.21348.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.13.21348.13001
  C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7\Plug-ins\import_ACAD.rhp	"AutoCAD file import: import_ACAD"	
  C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp	"Alerter"	
  C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.13.21348.13001
  C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp	"Grasshopper"	7.13.21348.13001
  C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.13.21348.13001
  C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Users\USERNAME\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp	"SectionTools"

Allow me to answer myself.

One work-around could be:

  1. select all dimensions to be adjusted,
  2. go to properties of selected objects,
  3. change the “length factor” on the “properties” pane, rather than editing that for the style of these dimensions.

Hi -

What happens when you disable both of these and restart Rhino?
-wim