Rhino Export STL ASCII / Binary at 0kb

I mean that Ascii export doesn’t work either. It says 0 triangles and both Binary and Ascii say 0 Kb.

@tim - any idea here?? I’ll install 6.24 and see…


I also get the same result with the current SR candidate.

If you’re getting 0 triangles then we need to see your geometry, something’s wrong.

Otherwise you’re very likely seeing a numerical rounding artifact. When I save a cube as a binary stl it’s 684 bytes. Maybe it should round to 1k, but it doesn’t. You can make a stl file out of a single triangle and then you get 0 for both binary and ascii. The actual size of the binary file is 134 bytes. If you run properties on the file in windows and it says it takes up 0 bytes on the disk.


Tim, as I understand it, for this user there is never anything but 0, not just on tiny files - I could be wrong.


@mitch1 does it also say zero triangles, at the top of the dialog ('Approximate size")?
Never mind, I see your response above.

So, if I understand, to sum up, you make a box in Rhino and Mesh the box and export that mesh to stl and get zero triangles… Correct? and did this ever work?


Right. I have not tried to export stl before with this Rhino version.

@mitch1 - sorry for all the questions - it just seems so peculiar… can you export a valid file to say obj format using the same process? (Cube > Mesh > Export the mesh)?


Export the mesh in what format?

Hi Mitch - I suggest obj format - I expect it to work, I just want to find out if this issue is specific to stl export.


I think I’ve found the problem. If I select to save as stl and then click the Options… button in the file selection window, I get the result I’ve described.

Instead, if I just say Save, then the options dialog opens with valid non-zero numbers.

Hi Mitch - I see that, thanks. But do you ever see the options dialog again or have you got that turned off? It looks like the one you get from poking the button has not had a chance to look at the mesh yet. Thanks for following up.


I haven’t turned anything off. The steps I took are:

  1. Select mesh object, Export Selected…, click Options… --> see zeroes


  1. Select mesh object, Export Selected…, enter a filename, click Save --> see valid output

Note: entering a filename in the first case doesn’t affect the all zero outcome.

So, normally, here at least, you should see that dialog if you click the Options button and then you should see it again before the save is completeted - as part of the process, whether or not you’ve looked at the Options from the button. The second one would be the ‘right’ one because the mesh has been processed. However if you are not seeing that second one, you may have checked this box in the one you see from options:


That would shut off the automatic one…


I’m not sure if what I see differs from what I should see, but that checkbox has been and is unchecked.

Are you saying that the expected behavior is to see the zeroes initially, with the box unchecked, because the mesh has not yet been processed?

Hi Mitch - when I export, regardless of whether I click on options and see the zeros, I get another look at that same dialog with valid numbers before the save is complete. I would only expect that not to display if the check box were checked… but since it is not checked, I am back to square one, I was pretty sure we’d figured it out, but I guess not. Does the resulting file have anything in it?


Yes. If I follow the steps using Save, the output is good. Functionally, I’m all set now as long as I set the options in the dialog that appears after Save.

But I’m happy to explore further if you think it’s useful.

Hi Mitch, thanks- I am still not 100% sure I know what causes the confusion, but if it is working for you, that is the main thing.