Rhino display lagging and flickering

Hello everyone. Suddenly I started experiencing some problems with a display. It seems like model is shaking back and forth when rotating and panning. It can be seen on a video attached.

Please note that the video is not an actuall issue, just an illustration of how the shaking feels. I am not able to record the issue any way. I already experienced this issue once. The problem was solved by setting laptop as a main display. Now it appears to happen on a laptop not connected to a monitor as well. Do you have any tips please? I have tried newest nvidia drivers as well as some older ones. Issue still persists.

Rhino 7 SR37 2024-4-16 (Rhino 7, 7.37.24107.15001, Git hash:master @ d2e42f70b9d3aa58f6053e2998a0db2abcd7555b)
License type: Educational, build 2024-04-16
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 6-15-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Ti Laptop GPU (NVidia) Memory: 4GB, Driver date: 7-12-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.67
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-12-2023
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\Jan-s\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.37.24107.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Try an Nvidia driver update first, these are nearly a year old. :slight_smile:

“I have tried newest nvidia drivers as well as some older ones. Issue still persists.” This is the older one. I had the newest one before.

My apologies, I clearly read incorrectly.

One thing to try if you have the drive room is finding a workflow where you can capture this process. As you have an Intel CPU, you can use the Iris Xe iGPU to use OBS to do a screen recording when you are working. OBS is quite efficient, so you can run a capture for a good 15 minutes and have a file you can work with to chop it down. That way, you can provide a more direct showing of this problem.

did you do a clean install when you installed them?

If not make sure to do so with the latest drivers. use the custom/advanced install method, then look for the “clean instal” checkbox.

Also many nvidia cards have a surdio driver and a game ready driver… which ever one you tried, try the other… some machines prefer one over the other and for the life of my I cannot figure out why, but it’s a thing.

Also make sure you are picking the correct OS… a win 10 driver may not be the same as a win 11 driver.

By suddenly, do you mean that a couple days ago you were not experiencing this behavior? Did this happen right after installing the latest 7.37 service release yesterday?

I started experiencing this today, but it was even before I installed update. I mean, I installed update in hope of resolving the issue.

I did clean install all of them. Tried studio and game ready ones, old and new :smiley:

Thank you David, OBS captured the issue. Heres the video.

I have a daft one again… I am plucking at straws…

Given your Nvidia GPU, do you have GSync enabled? It sort of looks like frame tearing that you get in games when the scanline cannot raster fast enough.

Unfortunetally I dont have “Display” option in Nvidia CP

What kind of laptop do you have, is there a driver option to switch from the integrated GPU (Intel Iris) to the discrete GPU (RTX 3050)? Nvidia has a function called Optimus that can do that. Otherwise there are some apps that can switch between iGPU and dGPU.

If that doesn’t work you can try to enable or disable Vertical Sync in Manage 3D settings within the Nvidia Control Panel.

Thank you everyone for cooperation. Issue went away by itself. I even think I didnt do anything that would make sense to be “issue solving”. It just disappeared while working on a model all of the sudden, as it appeared at first place. Windows is wonderfull OS <3