Rhino Cycles Rendering stuck at 1/xxx samples infinitely

I am trying to render a fairly complex architectural model with PBR textures with cycles rendering. When I switch to the raytraced viewport, the rendering starts as expected, but then reaches a particular sample and hangs infinitely. I just now opened the raytraced viewmode and it reached 34/1000 samples and has now stopped. By stopped I mean it won’t progress beyond 34 samples, however the render timer is still going, so it’s trying to continue the render but can’t I guess. When I use the “render” command, the same thing happens, however in this instance it gets to just 1 sample and then hangs there. I left the computer running all night and it never got past 1 sample. Same thing happens when I use ViewCapturetoFile. I really need to get this working ASAP. Any help?

This occurs regardless of the target resolution or sample count.

Please run the Rhino command _SystemInfo and post the result in a reply.

Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Educational, build 2024-03-12
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 15GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [98% battery remaining]

Hybrid graphics configuration.
Primary display: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 11-1-2022 (M-D-Y).
> Integrated accelerated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 10-11-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 545.84
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-11-2023
Driver Version: 31.0.15.4584
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.1.1.0
C:\Users\noaha\AppData\Local\Programs\Enscape\Enscape.Rhino.Plugin-net48\Enscape.Rhino8.Plugin.dll “Enscape.Rhino8.Plugin” 0.0.24068.1709
C:\Users\noaha\AppData\Roaming\McNeel\Rhinoceros\BlockEditNew\BlockEditNew.rhp “BlockEdit” 1.0.0.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.5.24072.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

It seems the rendering works properly when I open the model in Rhino 7

Please update your driver to the most current, which is for your 3070 at the moment: NVIDIA Studio Driver | 551.86 | Windows 10 64-bit, Windows 11 | NVIDIA

When you start the installation please choose Custom/Advanced installation and check the Clean Install checkbox. After the update has been done please restart Rhino and go to Tools > Options > Rhino Render and click the Recompile Kernels button. When the dots after the devices turn green you should try again if rendering is now any better. I’m assuming you’re rendering using the Nvidia GPU.

It probably wouldn’t hurt to update your AMD GPU driver either.

Yeah I’m using CUDA rendering with my Nvidia GPU. I’ve done what you suggested and that seems to have fixed the issue on some views, but oddly it now seems that the issue is still occuring on specific views in my model. Rendering is functioning properly with a couple different perspective views, but in my elevation views it’s still getting stuck. On one elevation it gets stuck at 1 sample, on another it gets stuck at 4 samples.

Yeah rendering in perspective works fine, but as soon as I switch to parallel projection in that same viewport the render gets stuck at a particular sample usually between 1-15. This occurs regardless of whether a clipping plane is active or not.

It’d be great if you could share the model that is causing problems. ZIP up all necessary files and upload it to Rhino - Upload to Support - I have prefilled my address. I’ll take a look at it after the weekend.

@CallmeCatbread - I have tested your model (I opened FINAL MODEL), and I see no hangs. Are you sure you’re using CUDA, and not OptiX? The latter has some problems with clipping planes that I have not been able to identify and fix yet: RH-77440 Rhino Render with OptiX hang using clipping planes