Rhino Crashes When I do simple movement or add some value in Grasshopper or Rhino

During the last two months, I received a lot of crashes from the program, I did most of the suggested ways, for example, updating Rhino, updating Windows, updating the graphics card, changing Windows, etc., but still no change was made. .
I must say that my system(Laptop) has 16 GB of RAM, RX 580 Graphic Card and Ryzen 7 CPU, I think it’s enough for simple work in rhino and grasshopper but it is bothering me.
HELP me Please, Thanks

Hello - please run the SystemInfo command in Rhino and post the results.


Rhino 6 SR28 2020-7-17 (Rhino 6, 6.28.20199.17141, Git hash:master @ b1f15b655bd1f5ae0d3d3257e3efdeb0a45630e4)
License type: Commercial, build 2020-07-17
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-TJ1GGPDC

Non-hybrid graphics.
Primary display and OpenGL: Radeon RX 580 Series (AMD) Memory: 4GB, Driver date: 10-16-2020 (M-D-Y). OpenGL Ver: 4.6.14736 Compatibility Profile Context 20.10.1 27.20.12033.1007

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 10-16-2020
Driver Version: 27.20.12033.1007
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
D:\Rhino\Plug-ins\Commands.rhp “Commands” 6.28.20199.17141
D:\Rhino\Plug-ins\WebBrowser.rhp “WebBrowser”
D:\Rhino\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Rhino\Plug-ins\RhinoScript.rhp “RhinoScript”
D:\Rhino\Plug-ins\IdleProcessor.rhp “IdleProcessor”
D:\Rhino\Plug-ins\RhinoRender.rhp “Rhino Render”
D:\Rhino\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.28.20199.17141
D:\Rhino\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
D:\Rhino\Plug-ins\NamedSnapshots.rhp “Snapshots”
D:\Rhino\Plug-ins\Alerter.rhp “Alerter”
D:\Rhino\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.28.20199.17141
D:\Rhino\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.28.20199.17141
D:\Rhino\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.28.20199.17141
D:\Rhino\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.28.20199.17141
D:\Rhino\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
D:\Rhino\Plug-ins\Displacement.rhp “Displacement”

Hello - that all looks reasonable to me - are you sending crash reports? Is there any consistency to the crashes - specific commands, or specific files that crash?


Hi, yes I always send when I got that. No for all the file and commands it’s same.

Hello - when you send the crash report, do you use the same email address as you have here on Discourse?
I am not sure that I understand what you mean about commands - can you describe in some detail what happens? I assume you do not just open Rhino and it crashes, you are working, doing something… what, exactly?


I send the crash report today, yesterday, …
Yes, I sent it with the same email that is here
For example, I am moving the camera, or I am changing something in grasshopper, or I am seeing a rendering display, Once the screen freezes and the program closes and saves the file on the screen and a new page opens to send the report.

OK, I do not see the reports, yet, but perhaps they are still being processed. Does the crash always involve the Rendered display mode. and/or is Grasshopper always running at the crash?


At the wireframe mode or etc.
not always but sometimes, I must say that Sometimes I work on baked object from grasshopper this is happening

@ars.sadt - can you please update Rhino to the current version (6.30, here: https://www.rhino3d.com/download/rhino-for-windows/6/latest ) and, have you got any emails back from us about the crash reports?


Sure, I will download it, I check my inbox Today, Nothing received.

Hello again, after about two weeks, sorry for my latenning, I tried a 6.30 version of rhino
But it is still the same problem as before, it happens again when i was in recording a video from kangaroo plugin in grasshopper, I can upload it for you

hi, now i test it again and i’m sure about it this is a rhino problem.