Rhino 8 Keeps Crashing When I Attempt To Open It

This is what it says.

[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for ‘CrossGemsGH.Display.DrawServer’ threw an exception. —> System.NullReferenceException: Object reference not set to an instance of an object.
at CrossGemsGH.Libraries.Materials._x1MBBEwUln546OvNGIFBlCK22jH(String )
at CrossGemsGH.Libraries.Materials.GetMaterial(PlasticType material)
at CrossGemsGH.Display.DrawServer…cctor()
— End of inner exception stack trace —
at CrossGemsGH.Display.DrawServer.AddPost(DrawObj drawObj)
at _5e._kgc(Object , RoutedEventArgs )
at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
at System.Windows.BroadcastEventHelper.BroadcastEvent(DependencyObject root, RoutedEvent routedEvent)
at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(Object root)
at MS.Internal.LoadedOrUnloadedOperation.DoWork()
at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
at System.Windows.Media.MediaContext.RenderMessageHandlerCore(Object resizedCompositionTarget)
at System.Windows.Media.MediaContext.RenderMessageHandler(Object resizedCompositionTarget)
at System.Windows.Interop.HwndTarget.OnResize()
at System.Windows.Interop.HwndTarget.HandleMessage(WindowMessage msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Sorry to hear that @sikim,

It sounds like a 3rd party plugin (CrossGems) is causing the issue, can you try running Rhino 8 in safe mode, it should load without plugins, and if that’s the case, it narrows down the issue.

how would I run rhino 8 in safe mode?

You should be able search “Rhino 8 in Safe Mode” in your windows search and it should be available to you.

Failing that, It can be found here
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Rhino 8.

And failing that you could run this from powershell or cmd & "C:\Program Files\Rhino 8\System\Rhino.exe" /safemode

Ok so I figured out that CrossGems is causing the problem. I use crossgems all the time and this is the first time that it is causing me any problem. What should I do? Should I uninstall crossgems and try installing it back?

I would try uninstalling and reinstalling it, and ideally trying the latest version of it.

What version of Rhino are you using, and does their software recommend a specific Rhino Version?

I am using Rhino 8 at the moment, when I load up Rhino, it says that there is an update available these past few days and I have always closed it out. The software crossgems is built specifically for rhino 8

if you’re not on Rhino 8.7 I’d upgrade to that as well as upgrade CrossGems, if that still doesn’t work, we can try some other things next :slight_smile:

How would I upgrade Rhino 8? I try to upgrade rhino 8 when I open it, but it crashes before I could do anything.

I think a fresh install may be in order for Rhino then. Why don’t you uninstall it, then reinstall it fresh from this link

If you have many custom toolbars and settings it might be worth backing those up first

i uninstalled crossgems and reinstalled it, it fixed the problem. Thank you!

1 Like

Glad you have a working setup again :slight_smile: