Rhino 8 - How to turn off "Tooltips / Pop up Infos"

I installed the new rhino 8 - and what is annoying while working with many layers is the “Pop Up” or “Tooltip” which appears whenever I want to work with the layers/ scroll the mouse over the layers name. I am not sure wether this is an error of Rhino 8 or just an attitude/ option (and I don’t know where to turn off)?

The problem is that the information/ Pop Up hides some other layers and that is very annoying if you have to change the settings of the layers very often.
So probably someone has the same problem and can help me ??

1 Like

At the moment AFAIK all you can do is move the mouse cursor off the panel, or onto any blank area you have below the layer rows. The Tooltip will vanish sharpish.

@wim , may I suggest adding a tickable option Layer Tooltips to the Layer Tools menu so users can choose to have the facility or not?

Hi Jeremy,
thanks for your answer.
That’s the hard way :wink: - always tricking around where to move the cursor …
But I am not sure if that’s just a problem of my installation / checked options…

Hi Michael -

There is no setting for this, no.
It looks like this worked just fine in Rhino 7.
I’ve added a note to RH-78260 Layer tooltip usefulness

Hi Wim,
thanks for the answer.
I just found this possibility for useful:

Pascal GolaypascalMcNeel

May '19

Hello - I think this setting in Options > Advanced page, is what you’re looking for-

That’s in milliseconds.


Yes, the layer tooltips in V8 are really annoying and buggy. Please provide a way to turn them off or something…


For me the intrusive pop-up information in V8 is a regression from V7. Perhaps someone considers it a “feature”.

Please either restore the V7 behavior or provide a way to turn them off.

1 Like

I suspect that it is an attempt to address the difficulty of identifying a layer when looking at columns at the right end of the rows, now that we have even more columns, without making the panel so wide we run short of drawing space.

Personally, I would prefer the ability to lock the name column so it doesn’t scroll sideways, as seen in spreadsheets.

I agree with you, it was better in Rhino 7. I was comparing Rhino 7 and 8 and found something else, and that is that in Rhino 7 the tooltips stay when hovering over different layers, whereas in Rhino 8 the tooltips turn off. I personally find it more user friendly if they just stay once they are on, but it would be good to hear your opinion about this.

I agree this would be useful, I added RH-78923 Layers: provide a way to ‘lock’ certain parts of the table

RH-78924 Layers: provide a way to turn off layer tooltips

I’m not seeing what oyur seeing.

In V7 I have no tooltips at all appearing in the layer box when I hover over a layer - IF the entire layer name is visible. If the layer name is long, then the tooltip appears - this is good and expected behavior. Yes, it turns off after about 4-5 seconds here, like all the other tooltips do.

In V8 I have tooltips appearing all the time - even if the entire layer name is visible in the layers panel. And, yes, they do not turn off until you move the mouse away. Plus they’re about two times as “fat” (vertically) as the V7 tooltips.

V7 (for about 5 sec on hover)

V8 (always on when hovering)

Notice also that V7 puts a ... where it cuts off the layer name to indicate there is more. V8 does not.

The V7 behavior is infinitely preferable IMO and I wouldn’t need to turn off tooltips for layers, because they only pop up when needed/desired. So maybe you can change that youtrack to reflect this.

Apparently Dale did not find a good way to see if a layer name is truncated yet, and for now will turn of layer name column tooltips until a solution is found.

thanks, I added RH-78928 Layers: indicate a layer name is truncated

This is indeed an issue (on Windows) that is logged as RH-78262 Tooltips are always 2 rows high
btw I also made this yt: RH-78584 Tooltips appearance