Rhino 8 Feature: Selective Clipping

RH-75238 is fixed in the latest WIP

Ok @BrianJ I found the problem. I was missing the ‘Use section styles’ checkmark in the rendered display mode settings…

1 Like

Hi, @rajaa
Both Make2D and Clipping Sections are only accepting one Clipping Plane at once. Your video shows the usage of multiple Clipping Planes. Will this change before shipping Rhino 8 and creating drawings cut by multiple planes will be possible?

Hi Jakub -

Rhino 7 accepted multiple clipping planes in Make2D, so this looks like a regression.
RH-76226 Make2D: Multiple ClippingPlanes

As for Clipping Sections, are you referring to the ExtractClippingSections command? That accepts multiple clipping sections and creates the result for each of those.
-wim

I’m referring to the ClippingDrawings command. There are some methods now, and it’s easy to lost between them. Hoping to see some cleanup. Make2D does a lot of things right (transfers attributes which is very useful) but it’s not updatable.

@Czaja I’m not sure I understand. Can you give an example?

I was making an example and encountered a bug. So this is for starters.

Clipping section drawings still produce sections of geometry that are already deleted from the scene instead of using new geometry. The update Clipping Drawings command solves the problem.

rhino testy ciecia.3dm (158.2 KB)


Rhino 7 - Make2D working as expected

Rhino 8 - Make2D only accepting one Clipping Plane at once

Command Create Clipping Sections creates sections that can be updated after input geometry changes (command Make2D can’t update drawings) but Create Clipping Sections can’t produce a single drawing where more than one Clipping Plane is taken into account (Make2D in RH7 can do that).

So the current situation is that we have multiple methods of creating Section Drawings but every method has different limitations. I’m asking for one method that will produce 1 updatable drawing of geometries that are cut by more than one Clipping Plane at once.

2 Likes

Hi @Czaja
About the using deleted geometry, I see it. Logged here…

There is a bug in the Make2D selective clipping. Similar bug is reported here…

As for using multiple clipping planes in one section, this is not supported. The ClippingDrawings command extracts sections of each clipping planes (even if the clipping planes is not active in a viewport). Added a request to link more than one clipping plane to represent one section here…

Hi Jakub -

image

For that specific example, what does the 2D drawing look like? Or do you want a 3D perspective result?
Note that, simply using clipping planes and putting the viewport in a technical display mode will now produce vector drawings when printed to PDF.
-wim

2 Likes

I would like to have a 3D perspective drawing similar to what I can get with Make2D.
As it goes for the Technical vector pdf, it’s not working for me. I get a raster drawing with some extra glitches.

Layout view

PDF

I’ve seen other user on forum having trouble to output vector technical drawing to pdf but I can’t fint his post now.

@rajaa
Thanks, I’m sure you noted everything but just to let you know, your links aren’t publicly accessible.

1 Like

This is now fixed.

Are you saying multiple clipping planes are not going to be supported in Make2D in V8? Why? For me, it renders this feature much less useful.

Hi Ryan -

Rajaa’s comment was about the ClippingDrawings command, not Make2D.
-wim

1 Like

It would be great to see multiple clipping planes working again with Make2D, as they did in Rhino 7, but in Rhino 8, with support for the section attributes. :hand_with_index_finger_and_thumb_crossed:

@user2745 this is reported here…

Hahoo!! Really pleasantly surprised by this feature!!

I noticed a minor bug in the display.
If you move the plane and press ESC, the window does not display correctly.

jmv

Thanks.
RH-77090 Display: Clipping plane section is not drawn after Esc
-wim

Hi @BrianJ, I just opened this file again and something seems wrong with the PBR material.

selective_clipping_issues.3dm (3.7 MB)

I’m also adding a new file with the mesh of an apple inserted and imported. Note how the clipping plane clipps the apple no matter if it is inserted without embedding or imported.

But the trick with the color does not work when the content is inserted.

Something with the texture is also not so nice when the clipping plane is moved.

I deleted one of the inserted objects so the file got a bit smaller. I had to zip the *.obj of the apple since it contains a an *.mtl file which doesn’t seem to be allowed to upload?

apple_scan_import.3dm (13.8 MB)

apple.zip (3.6 MB)

1 Like

Hi @martinsiegrist ,

I’m not seeing the procedural wood have an issue here so it might be a driver issue at a guess. The file may also be different maybe from the one uploaded, the ground plane doesn’t look the same in my test. DM me your SystemInfo command results or reply here with it.

The apple issue appears to be due to it being a block. Filed as https://mcneel.myjetbrains.com/youtrack/issue/RH-77907 Thanks. I was able to Explode the block and then reset the mesh to use the clipping plane for the section style.

1 Like

Thanks for your feedback @BrianJ

Interesting, I cannot reproduce the problem in this file here:

procedurals.3dm (642.8 KB)

And here’s my

System Info

Rhino 8 SR0 2023-10-24 (Rhino 8 BETA, 8.0.23297.13303, Git hash:master @ 4368ce4c82870d4ce7b0ef004198da23d48ffe5f)
License type: Kommerziell, build 2023-10-24
License details: Cloud Zoo
Expires on: 2023-12-08

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 1.3e+02Gb)
.NET 7.0.13

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA RTX A5000 (NVidia) Memory: 22GB, Driver date: 8-14-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.13
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
NVIDIA Quadro K2200 (NVidia) Memory: 4GB, Driver date: 8-14-2023 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-14-2023
Driver Version: 31.0.15.3713
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 23028 MB

Rhino plugins that do not ship with Rhino
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\EleFront\4.2.2\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.4.0.0\KeyShot9RhinoPlugin\Rhino 7\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin” 1.4.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\MeshCommands.rhp “MeshCommands” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.23297.13303
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”