Rhino 8 Feature: Selective Clipping

I also don’t see the issue in that file. There’s nothing that jumps out in the system info but I might reconfigure the RTX A5000 GPU to use port 0 for the main monitor. This may not matter at all but it’s what I’d do. I might also update the driver although it’s pretty recent and you are still on Windows 10 so again maybe that isn’t needed too. You’re also not seeing the issue now so perhaps it had to do with something else at the time you did.

1 Like

Updated to Windows 11 just now and I don’t see the problem anymore, also in this file.

Everything works fine.

Note: If you’re going to want to change how Section Styles work for blocks, then you must make sure that the “Section Style” setting for every object in that block is set to “By Parent”… Once you block an object, all attributes are locked into that block and will remain fixed regardless of what attributes you assign to that block.

  1. Unblock the apple - you’ll notice its Section Style was set to “By Layer”
  2. Change the Section Style for the apple to “By Parent”
  3. Reblock the apple

Now if you assign “By Clipping Plane” to the block’s Section Style setting, the apple inside the block will also take on that setting.

Hope that makes sense.
-J

1 Like

Thanks for the reply, @jeff

This particular block is an inserted *.obj file with the option embedded and linked.

The apple is just a simple example but I’m regularly working with many heavy scans referenced in the same file.

The thing with the linked block is that the file size remains really low.

You suggested unblocking / exploding the block. That’s not possible on a linked block *.obj file.

Somehow the block and its content must get their section styles and while I can find ways around this, it would be amazing if there was a way which does not require rebuilding the block.

It’s possible to reference the inserted block in Grasshopper and the clipping section works on the Grasshopper object but I see no cap

Ok, so I think I figured it out. I can set a section style on the block layer.

This is a little confusing :slight_smile:

1 Like

Agreed!

I’m not sure how we can get a link block (which imports from a .obj) file to have specific “By Parent” attributes set…either automatically or manually set by you.

Perhaps @dale and/or @mary can help here, they know a lot more about block organization than I do. I just “display” what I’m given :wink:

If the apple was in a .3dm file (instead of .obj), then you could set its Section Style to “By Parent”…Then linking to it instead of the .obj would work as you’d expect, because the block would inherit from the object’s settings. If you’re working with .obj files, this may be necessary to get what you want/need.

-J

1 Like

The *.obj is exported from Artec Studio. The linked file allows exporting the same file again if I have to and what I have in Rhino can be updated so this is a great feature.

Let me check with @tim to see if something can be done during import of .obj file…

-J

1 Like

You can try with the files in this post.

Ok, so it looks like I can set the Section Style to By Parent for objects being imported from a .OBJ file during an “insert” operation… Opening your original file with the reference to the .obj works now… The block’s Section Style is set to “By Clipping Plane” and the linked block displays as expected now.

This was just an experiment to see if it could be done…whether or not it should be done is another matter that we’ll need to discuss internally.

-J

1 Like

@martinsiegrist I’ve just added a small change that forces objects being imported from OBJ files and inserted into a linked block to have their “Section Style” source set to “By Parent”. This allows you to continue doing what you’re doing, and changing the style source for the block object will now affect the mesh(es) inside that block.

Loading your apple file with the linked “apple.obj” now yields this:

Hopefully this gets you a little bit further along.
-J

2 Likes

Thanks Jeff.

Will this be available in the next BETA release?

It should be, yes.

-J

1 Like