Rhino 8 fails at trim which worked in Rhino 5

Continuing the discussion from Where is the best thread making video featuring correct method?:

I’ve spun this off as a separate thread because the original has become a sprawling multi-topic mess…

While testing a mutual trim I found that what worked in R5 no longer works in R8, notwithstanding my computer fans signalling that R8 was consuming way more compute power, for substantially longer…

To reproduce, use the original surfaces, select the grey and red objects, Trim and remove the RH end of the thread and the part of the red cap that extends beyond the thread outside diameter.

This works in R5.

Try the same in R8 and it fails to trim the thread correctly.

Note that creating an intersection curve from the grey and red objects and using that as the basis of the trim works instantly and apparently correctly.

Rhino 8.0.23297.13303, 2023-10-24

thread_end5.3dm (827.6 KB)

thread_end8.3dm (989.8 KB)

Hi Jeremy - thanks, I see that.
RH-78036 Trim fails