Mutual trim fails

I’m trying to do with the red surfaces what I already did with the green:

But it fails… and the trouble is, it doesn’t tell me where it fails, so I don’t even know where to begin to look… why isn’t Rhino more informative here, and are there tools to make Rhino display that information?

If I do intersection curves, they look fine!

mutual-trim-fail.3dm (199.7 KB)

Hello - this trim will fail where the intersection is not complete - is that what you mean?


Onen method to make the trim work:
Intersect the two surfaces.
ExtendCrvOnSrf the intersection curve on the surface to be trimmed (surface which extends past the other surface).
Trim the surface using the extended curve.

You’re the one who taught me mutual trims with an arbitrary amount of objects, and now you’re showing me just two objects? :slight_smile: It’s a half enclosed volume by four overlapping surfaces. Intersecting all of them yields a continuous curve with no gaps:


Similarly, mirroring all of the objects and using CreateSolid also fails, which I don’t think is right…

This edge needs to be extended to fully intersect the (almomst) horizontal surface. There’s a 0.049mm gap there.

HTH, Jakob

1 Like

If you select all the surfaces and run Intersect, you get 5 intersections. While those are selected, you can run Trim and trim all the parts you don’t want away. You need several clicks of course…

Damn, now I get what @pascal was saying, thank you!

But this just reinforces my view that this option is a complete lie:


I’ve never seen it actually do anything! :laughing:

Also, imagine if Rhino could put a big red X at the spot where it fails, so people wouldn’t have to go on forums and ask people to play detective? (Better yet, what if the cutting lines would actually be extended so this just worked? Because I took the surfaces into another CAD package to finish the job and it did exactly that.)