Rhino 8 CPlane keeps changing

I recently upgraded to Rhino 8, and I’m encountering an issue with the CPlane. Its orientation keeps changing without any apparent reason. As a temporary workaround, I’ve been consistently setting it to ‘World Top’ in the NamedCPlane settings.

I would greatly appreciate it if someone could help me resolve this problem.

It’s not a problem, it’s a new V8 feature. The AutoCPlane function is turned on by default in V8 - if you don’t want it, click in the status bar where it says Auto CPlane to turn it off.

Having that on by default was a mistake.

1 Like

Well, McNeel wanted to make sure everyone who tried V8 knew it was there… Judgement call.

I can tell this will be one of the more frequently answered questions here in the next few months…

Well so far everyone who’s asked about it thinks something is broken, so I would say it was a mistake to change such basic behavior by default. I’m not sure it’s even that useful a feature unless your model is exclusively flat curves and surfaces, seems kinda awkward so far. It’s like the purpose of it is to enable someone to do a contrived demo that makes it look like SolidWhatever with “base planes” for features.

1 Like

Well, turning it back off by default is not hard to do in a future service release - if they decide to do so… It’s not a breaking change.

Thank you!!
could you explain what is autocplane for?

1 Like

Hello- AutoCplane allows you to draw curves on the fly on existing faces in a model. Since all input normally goes to the CPlane, with AutoCplane, you select a face to draw on - at any location or orientation, and drawing will ‘work’ automatically.

-Pascal

4 Likes

Thank you!

1 Like

Hi, I’m having an issue on Rh8 for mac where the cplane remains set to the object that i’ve used autocplane on.

Very nice feature otherwise - super useful!

In the status bar, right click in the AutoCPlane box and uncheck “Sticky AutoCPlane”.

1 Like