Rhino 8 BETA feedback

Yes, you’re right, if I turn it on it works.
So, how to turn off just the new mouse-hovering “dynamic highlight” and still able to select objects like before?

(I mean, I like to have it behaving like Rhino 7:
that it just appears AFTER cmd+shift+click to sub-select, not before the click.
The reason is that i always have cmd+shift pressed while browsing my models, because it’s also the keys that used to orbit around an object in combination with mouse right click by default)

With less words: can it be disabled with mouse-hover and act just like before?

for subobjects, there is:

1 Like

Hello @Gijs , here are two other bugs in the last public beta (8.0.23264.09004, 2023-09-21) for Mac:

– when opening a 3dm with missing attached images, I have a hard time selecting the broken links from the list:

– toolbars acting differently from each other when active (see title bar). I don’t know if that’s actually a bug, but can you at least keep the same width (or thickness) of the title bar between the tabs, to avoid everything moving up and down? Who’s responsible for the GUI design in there? :confused:

I know these are whims, but:
Do you think the slow pop-up thing will be taken into account?
Also, could we have the right-click contextual menu back? I’d like to have the possibility, as in v7, to quickly switch between Display Modes / Set Views directly from the viewport without having to reach the upper left corner of the screen every time.

Thanks for your work and your patience :slight_smile:

1 Like

Window 10

Testing Rhino 8 Beta (Serengeti)

  1. Made a block (Block 01) in one file and saved it (File “A”).
  2. Attache the previous file “A” (with block) to an empy new file “B”.
  3. Used the copy (type in command) and select in place.
  4. Saved file “B”
  5. Detached “A”, block gone (Reopened “B” to verify if it still the (Rhino 7 bug) might be there )
  6. File “B” empty … according to help/documentation it is possible to copy from an attached file
    to the current. Tried also copy and to a new location in “B” that failed too.

I hope it’s possible to fix this problem. Being able to copy blocks into current from other files
attached through worksession (as in Rhino 7) handy (IMO).

A post was split to a new topic: Text disappears from panels

A post was split to a new topic: Clipping borders inconsistent width

I cannot repeat this issue here

Of course the way it behaves at your end is not how it is designed. Unfortunately, I can’t repeat that here. It should show Properties: Object or Properties: Viewport

I’m sorry, but I don’t know what you are referring to

RH-77308 Rhino for Mac right click menu no longer shows view related settings

yes please…

This thing, which is ultra annoying, especially during a long session with v8

1 Like

well there is good news, this one has a good priority and will be resolved soon. that one also annoyed me… incredible apple style, having to watch slow animations while you are in a rush (often).

I think we all agree it is annoying. Once it get fixed, this thread gets notified

there is a problem with isotrim in 8 beta…works in ver7

isotrim-problem.gh (8.3 KB)

Hei Odd -

I’m seeing the same behavior in Rhino 7 here.
I searched our issues database and found a report that might be the same issue that was reported for Rhino 5 - RH-12910 - but I’m adding this thread to open item RH-59102 Worksession & block instance copy

Hi Giusseppe -

Thanks → RH-77330 Grasshopper: Isotrim issue with extrusion objects

I have mentioned this before but not seen anybody else troubled by it…if I have rhino 8 sharing my screen with GH or I have GH fullscreen, when I try to open a file or save a new file in GH I only get a small window as in the picture and have to move to another desktop and back before the full file manager window appears.
I have never had this with other versions of GH / rhino so I know that it is not just my mac.

On Rhino for PC, the function of relocating the Gumball while holding the CTRL button is unavailable. The double-click option might be suitable for some users, but in my workflow, it feels less precise for me as it makes my sensitive mouse cursor move on the second click.

1 Like

Thanks :slight_smile: the recent Beta update (8.0.23278.13003, 2023-10-05) has solved this
issue to Rhino 7 way of working.

But there is one more issue: If the copy block inplace option is choosen and e.g.
the reference layer is switched off/or referenced file deattached, the block looks
like it’s gone. Then save the current file close/reopen, then the block is where it
was copied.

This fooled me several times in Rhino 7 until I figured out how it worked.

This problem is not critical but a bit annoying especially if You work with a big
model (got to save/reopen) to be sure the block copied is there.

Got a work around copy (not in place) / move block back to the initial position.


I just found another ghost button

Hi Andrea -

I’ve put this on the list as RH-77783 StatusBar: Inactive button

In this issue it is said MAC-ONLY ISSUE, but I see it on Windows as well.