Rhino 8.2 Error occured loading plug-in RhinoCodePlatform.Rhino3D

Just got an error pop-up when installing the latest service release of Rhino:
image

Don’t know what effect this has had on my install or rhino functionality but it doesn’t sound good. Is this serious? Any thoughts on how to fix this or whether it doesn’t need fixing?

Thanks!

Here’s my system info:
Rhino 8 SR2 2023-12-12 (Rhino 8, 8.2.23346.13001, Git hash:master @ dbefe46c12cda06610a9ab683a211aa3d16f0030)
License type: Commercial, build 2023-12-12
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 64Gb)
.NET 7.0.14

Computer platform: LAPTOP - Plugged in [94% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port 1
Primary OpenGL: NVIDIA GeForce RTX 3080 Laptop GPU (NVidia) Memory: 16GB, Driver date: 8-4-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.99
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

Secondary graphics devices.
DisplayLink USB Device (DisplayLink) Memory: 0MB, Driver date: 6-28-2023 (M-D-Y).
> External USB display device with 4 adapter port(s)
- Secondary monitor attached to adapter port 0
DisplayLink USB Device (DisplayLink) Memory: 0MB, Driver date: 6-28-2023 (M-D-Y).
> External USB display device with 0 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-4-2023
Driver Version: 31.0.15.3699
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

A little more info:

  • after getting this error message Grasshopper also failed to load… so that’s not great.
  • tried downgrading to 8.1.23325.13001, 2023-11-21 and successfully loaded with no issues.

Hi Jo, lets get you on the 8.3, there are a lot of updates to the CodeEditor. (go to the Help>Check for Updates)

Unfortunately, that build isn’t working for me either.

Lets start grasshopper from the Rhino command line GrasshopperLoadOneByOne command and see if we can find a conflict (say no on the first run to all and see if the error persists)

right away: image

Same problem for me… I’m on SR4

I eventually solved this, but looks like that was in a private message:

Well, I seem to have fixed it… there was an extra version of Grasshopper.dll hanging out in the Rhino 8/System folder. I deleted that and now everything is working again. Weird. Don’t know how that got there.
Tip off was that Rhino couldn’t find Grasshopper.dll, and the duplicate Grasshopper.dll (in the System folder) had a timestamp from 2023, so it hadn’t been a part of the Rhino8 install.

Maybe this will work for you, @Martin_D ?