Rhino 7 takes over ten minutes to open

Whenever I try to open Rhino 7 up I have to click on the icon 18 and counting times. It shows the loading icon on the mouse and then disappears and nothing happens. I have talked to some of my friends in our class and the same issue happens to them, only I am less patient and want this issue fixed. It will end up opening but it just feels wrong for this to keep happening. I am constantly fearing my computer will shut down or update and Rhino will close bc it takes so long to open back up again.

once rhino runs, please run the systeminfo command and post the result here.

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Evaluation, build 2021-03-19
License details: Cloud Zoo
Expires on: 2021-08-02

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 12Gb)

Computer platform: LAPTOP - Unplugged [74% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 2-19-2020 (M-D-Y). OpenGL Ver: 4.6.0 - Build 26.20.100.7925
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build 26.20.100.7925
Driver Date: 2-19-2020
Driver Version: 26.20.100.7925
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Users\serra\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.1\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows” 0.5.1.0
C:\Users\serra\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.2\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.2.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

please run help>check for updates in rhino and grab the latest service release-

and also realize this machine is not set up well to run rhino. It’s below our spec of 4 gb of vram.

Once you update- you may try moving this slider to the left to see where you performance improves.

you may also want to update your intel driver here-

use the update tool-

1 Like

Thank you so much!