Rhino 7 - Reflect

Hi … A simple question why Reflect command in Rhino7 SubD is not working ?? it has been working before in WIP, but now after I got the authorized Rhino7 is not working anymore . Thanks

Sometimes the command ToolbarReset and a restart helps

Dear Martin

I did what you’ve asked about … unfortunately still not working
what on earth could that be? : (

Working here. What is the issue? Please be specific. Does the command not show up? is the button missing? is the command prompt not running? is it not reflecting? Give some details and images.

Please assign your new messages to the appropriate category so the right people are more likely to see it.


@John_Brock you’re on a crusade today! :wink:

I was off yesterday, so there were 8 uncategorized messages.
My goal is to train people to categorize their messages so they are quickly seen by the people that can help them.



it is simply not reflecting. the dark gray zone is there but it is like both sides are editable = no reflection

you corrected my bad forum etiquette, so your techniques are effective :wink:

Hopefully they aren’t so heavy handed as to leave a mark…


As @Michael_Pryor suggested, more words are usually helpful describing your problems.
What seems obvious from one perspective may be off the radar completely from another.
In this case, I try Reflect on my computer and see that it works then have no idea what to try that would duplicate what you are doing.

Anyway, assuming that when you run the Reflect command and answer the prompts you get a symmetrical shape that’s half dark gray, but changing the light colored side doesn’t cause the dark side to change, explain exactly what edit you do to the light side and upload a file that has the symmetry set but doesn’t update.

Also, include what specific version of Rhino you’re using ie( 7.2.21041 ).

  • I am using : Version 7
    (7.2.21021.7001, 21-01-2021)
    Educational Lab License
    SN: 6-1700-0104-1-362-57225
    Windows User, KGLAKADEMI

*when I run Reflect command the 2 halves get adjusted symmetrically & one half is grayed out. but afterward when I start to edit it is not reflecting. I could even edit the gray half! which should not be possible if it was working?

  • To be very specific I can send you the file if you like. (& if I know where to send it : )

I have of course tried in other files, new file, new primitive geometries. reset Tools, restart Rhino, restart the PC. it fails always. that means it is not related to a certain file but rather to my Rhino7

Thanks for the info.

Do you mean that you make some edits that update symmetry, then as you’re editing, the updates stop working?
Or when you reopen the file updates don’t work?
Is there any event that seems related to the Reflect updates stopping?

Please do send a file. The easiest way if it’s not too big is to drag the 3dm file onto a post here.
If you don’t have an example small enough to do that, you can send it here: Rhino - Upload to Support - Put in the comment there that it’s for me (lowell@mcneel.com).

Hi Lowell … actually I have no file cause I stopped in modelling the chair from the start once I found the symmetry is not working (the I worked in stead in Fusion 360)
But I even want to send you just an empty file with a subD cube saved in my Rhino7. Maybe you can see something wrong there
Thanks very much for care

Hello - yes, please send a simple file where Reflect as been applied and does not update.


Here’s the file:
Reflect_problem.3dm (197.1 KB)

There was a bug where updating stopped with History updating turned off, and did not come back, I wonder if that is what happened to this file.


Good. I forgot that.
@samerhanna - Please check that history update is enabled.
Right click Record History on the Rhino status bar and verify that History update is chexcked and Lock Children is not checked
Then see if Reflect works right

Okaaay ! Intersecting! so the update children should be checked !
I am sorry I get a little confused about Rhino history & SubD reflect. I thought that Subd Reflect controls that automatically, specially when I see the gray tone.
& I know that it’s not possible to work with history always on. (I teach Rhino to architects)
grateful for your support :pray:t5:
well… I catch then this opportunity to ask you some issues in SubD:

  • What is option “Snap to reflection plane ( SnapStyle=Automatic ): SnapStyle
    SnapStyle ( None Automatic Distance )” ??? I could not find it in F1 (help)

  • Why there is no toolbar button for MultiPipe that is actually a subDpipe (which is a powerful command) ?
    there is an option inside pipe (multiple) but it is another thing.
    & I know that you can create your own button by painting some pixel … but i would be nice to call it SubDPipe & give it the concession like Sweep etc.

  • Why there is not HotKey that toggle the activation of SubD selection vertex, edge, face by one click? like in T-spline (instead of filter). I know you can make your own aliases but then you have to click for the alias (maybe 2times on a letter then Enter to confirm the selection mode = 3 xclick)

  • why there is no radial symmetry ? I saw they make a polar array with history active. but this could not always be the case that you have a separate element. what if you want to apply it to a face within the shape?

Again 1000 thanks a lot for your help