Rhino 7 Not Opening

Hi, So I’ve been looking around this forums trying to figure out why my Rhino isn’t working and have tried everything posted. But it still doesn’t launch. I can see in my Task manager that the application has launched, but the app doesn’t pop up.

But apparently they gave me this Notepad to look at (but I’ve converted into a PDF to be able to upload), and I’m not sure what it means.

So if anyone can help, Id appreciate it a lot.

Rhino_7_20210322181946.pdf (52.4 KB) .

Hi -

Who is “they”?
Have you rebooted your PC and is your Windows installation up-to-date?

Yes, I’ve tried rebooting my PC and my Windows is up-to-date and it still didnt work, However I am currently using a ASUS Rog Strix. By they Im referring to the Rhino 7 app itself, because I left the app running in the background (without force quitting it, even though the app didnt launch) for a few hours and it gave me that notepad file.

Also, this is the Laptop spec:

OS Name Microsoft Windows 10 Home Single Language
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name LAPTOP
System Manufacturer ASUSTeK COMPUTER INC.
System Model ROG Strix G713QR_G713QR
System Type x64-based PC
System SKU
Processor AMD Ryzen 7 5800H with Radeon Graphics, 3201 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date American Megatrends International, LLC. G713QR.308, 12/30/2020
SMBIOS Version 3.3
Embedded Controller Version 0.41
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product G713QR
BaseBoard Version 1.0
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = 10.0.19041.844
User Name LAPTOP\User
Time Zone SE Asia Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.4 GB
Available Physical Memory 27.0 GB
Total Virtual Memory 36.2 GB
Available Virtual Memory 29.3 GB
Page File Space 4.75 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Is your video card driver up to date?

Yea Ive tried, and it still doesnt work. But for some reason, Rhino 6 launches but not 7.

Does Rhino 7 run in SafeMode? (Start>Programs>Rhino 7>Rhino 7 in safe mode)

No, I cannot run it on safe mode :confused:

Hi - have you ever been able to run Rhino 7 on that machine or is it the first time that you are trying? Have you tried repairing the installation in the Windows control panel?
In Rhino 6, please run the SystemInfo command and copy-paste the result here.

So, Ive tried opening Rhino for a second time and I noticed that it doesnt work. But when I open it in safe mode, it opens. Here is my SystemInfo. How do you think I should proceed?

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Evaluation, build 2021-03-19
License details: Cloud Zoo
Expires on: 2021-06-20

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 31Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: AMD Radeon™ Graphics (AMD) Memory: 1GB, Driver date: 1-7-2021 (M-D-Y). OpenGL Ver: (null)
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
NVIDIA GeForce RTX 3070 Laptop GPU (NVidia) Memory: 8GB, Driver date: 3-10-2021 (M-D-Y).
> Integrated accelerated graphics device with 4 adapter port(s)
- This device is not being used
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 1-7-2021
Driver Version: 27.20.14016.7001
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 512 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001

Swap your monitors.
Make the laptop screen primary and the external secondary

Additionally, ASUS installs a utility that causes trouble with 2nd monitors.
To test, see if Rhino comes up on the built in monitor and runs correctly with no second monitor.

You might try a clean install of the gpu drivers - not sure what the above ‘n/a’ ‘null’ really means but somehow does not look all that promising for Rhino.