Rhino 7 freezes/loads after selection (much longer than Rhino 6)

Hello there! :slight_smile:
I thought this might be a known issue and hoped to be fixed, but as it seams I still got this problem so far:

After selecting something - either a simple polyline or a complex shape/srf, doesn’t matter what - most of the time R7 stands still for qite some time. (Of course, the more complex the longer - but you get the idea.)
It feels like “Autosaves” everytime I do a selection. Rhino 7 becomes unuseable in that time frame.

Rhino 6 does a better job here - I don’t know why.
Just as a quick example - selecting this town model, all grouped surfaces (I just had it open):

Rhino 6: 2 seconds
Rhino 7: 110 seconds

I hope there is a fix!
Thank you in advance,
stay healthy,
blind apple :slight_smile:

My Rhino 7 System Informations listed below:

Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ed629035202f07e8b84a3ee211479ca20bb81b73)
License type: Studentenlizenz, build 2021-03-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - please disable VRay in Options > PlugIns page, then close and reopen Rhino - is that nay better?


Thank you for quick reply!

No. :confused:
Vray turned off - still same time passed: 110s

In Options>Advanced, if you uncheck the following setting does it help?

No, didn’t help either.
Still exactly 110s.

Wait - - does it actually Autosave all the time? What are the Autosave settings?


No, sorry, I may have not explained myself clear enough - sorry!
It only feels like an Autosave - I don’t think Rhino does actually make Autosaves.

I just know it from other software (like 3ds max) - you are about to do something - freeze - “Autosave in progress”.

Sorry, this is on me!
Rhino just loads all the time for some reason - no Autosave - just checked the Autosave folder.

Hello - can you try one more thing - do a SaveAs, to a different name and make sure ‘Save plugin data’ is not checked - does the resulting file behave any better? As you can tell, I still kinda smell Vray here…


No, not better.

I will try to uninstall VRay after and keep you up to date in a minute or so.

OK, it is probably not Vray or a plug-in then. I don’t think there is any need to uninstall, yet, anyway. We’ve seen plug-ins affect things in unexpected ways, so I always try to eliminate that influence first and take it from there.
Does any large file behave this way? @rfollett is experiencing what I think is very likely the same problem but I cannot pin down the cause. Can you send us a file, to tech@mcneel.com ? I have not been able to reproduce this so far with the example file we have, but I can try again, and maybe can find something that is common to both.


Ok, no VRay installed - still 110 seconds.

Thank you very much!

For me, in V6 it takes about 1/2 second to select the grouped buildings.
In V7 its quicker yet.

Our systems are very similar too.

Desktop with 16 GB RAM.

I’m running an Nvidia Quadro P2000 driving two 27" monitors connected directly to the Quadro GPU ports.

I’ll check with Pascal.

Hello - is selection slow if the Properties panel is closed?


1 Like

It is the “Box Edit” Panel that is open, causing the delay.
"Transform objects individually" was checked in R7, unchecked in R6.

Thank you!!!

Feeling bad now for my mistake! I am sorry.
Thank you very much for your work!
You are great!

blind apple :slight_smile:

Ahh, interesting - let me check with the other user reporting the problem - thanks for the update.
@rfollett - is BoxEdit open in your case?


i dont have the boxedit panel open…

I ran the command Boxedit and checked that flag was off… it was off, i closed the panel…

is our file available for download so I can test ? thanks


But I don’t think this file in particular will show your problem - since mine was only Rhino calculating all measurements of all 7000 objects in two minutes or so when the BoxEdit Panel was open (Transofrm objects individually checked) - so independent from the document itself.

But let us know!

Greetings, blind apple

thank you… Tested and yes you are right, no issue…