Rhino 7 Freezes Computer

Hey y’all!

Rhino started freezing my computer.

  1. launched program
  2. loaded (any) model
  3. nothing shows in wireframe, geometry is visible only in the rest of view modes, like ghosted, rendered, etc.
  4. while NOT in wireframe, i can move geometry around and move around in the viewport, but selecting object is not indicated, AND
  5. as soon as i try to perform an operation, like for example bend an object, my computer freezes.
  6. switch to wirefame, my computer freezes as soon as i zoom with the scroll button or do anything to geometry.
  7. ghosted mode in Left view is an instant kill.

Launched Rhino in Safe Mode, to see if it makes a difference:

  1. When loading a model, selected “No” when program asks to load RhinoRender.rhp
  2. Everything works fine, geometry is visible (obviously i only have wireframe) and I can perform operations.

Things I tried to no avail (not in Safe Mode):

  1. Waited… for a long time, in case it’s just a bad lag.
  2. Updated to latest candidate.
  3. Updated VGA driver
  4. Uninstalled and reinstalled Rhino.
  5. Installed all Windows updates.
  6. Read a bunch of forum posts.
  7. Started disabling plugins one by one, loaded a model every time I disabled a plugin, then restarted Rhino when nothing showed in wireframe (thus the problem is still present). The only two loaded plugins remaining were toolbars and commands.

McNeel Update Service 5.0 is running.

I’m out of ideas.

Can anyone help?


Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Commercial, build 2022-11-04
License details: Stand-Alone

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.

Primary display and OpenGL: Radeon RX 560 Series (AMD) Memory: 4GB, Driver date: 11-10-2022 (M-D-Y). OpenGL Ver: 4.6.0 Compatibility Profile Context

> Accelerated graphics device with 6 adapter port(s)
    - Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-10-2022
Driver Version: 31.0.12029.7019
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 20190 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Try turning down the OpenGL slider in the options. Your AMD video card’s OpenGL support is just not great, someone with a 580 was having trouble a week ago and that fixed it.


Try moving the slider in Options>View>OpenGL 1 notch to the left… does that help?


Woah! Thanks, both of you’s!!! It worked!!!

Worked for me too (with a 580). Thanks :grin:

Same to me, with a RX 570.

Worked for me also with a 560 4 GB!! Many thanks!!

Made an account just to say that after trying lots of things this was the solve for the freezing problem. Big relief.