Rhino 6 WIP for Mac - Download link leads to "Server Error"


#1

https://www.rhino3d.com/download/rhino-for-mac/6/wip

Using this link and entering my email and Rh5Mac licence code, I see a page that says:

Server Error
Please visit http://discourse.mcneel.com

Is it me, or is the dl link broken?


(John Brock) #2

I’m guessing it’s you or something blocking you.
It’s working fine for me.
I’m using Chrome.


#3

Hi John,

Thanks for getting back.

I tried the following configurations:

  • Mac OS, Chrome
  • Windows 10, Chrome
  • Windows 10, Edge ( I browser that I never use to ensure no Ad-block-etc Plugins are installed)

Same result in all 3 cases

Just to rule out another scenario:
If something was wrong with my credentials, I would assume to get a proper error message (like “We cannot find your email address” or “your licence code is wrong”) Correct?

What else could be blocking me?

Any hints appreciated.


(John Brock) #5

There must be something on your end that is blocking it.
If this is a laptop, can you try from your home connection?
The download does do a redirection from the license checking to a staging server where the installer is hosted. If you are blocking redirection, I suppose that could cause what you’re seeing.


#6

Hi @John_Brock

Thanks again!

I tried home, work, hotel, airport, … in different contries. Chrome and Firefox this time.

I normally do not suffer much from download issues, server errors or pages being blocked. What I mean to say is: We don’t have a restrictive corporate network or anything. My network at home is pretty much standard.
I google-searched for anything like “unblock redirect in chrome”, found nothing at first glance and my lack of IT administration skills won’t take me any further.

I am not really convinced that the problem is on my side, as I tried at least 4 different networks, 2 different computers/OSs and 3 different browsers (in two different counties, if that matters).

Any other suggestion what I could try to get my hands on the Rhino 6 WIP for Mac?

TIA
Best,
Frank


(Dan Belcher) #7

Hi FrankS-

Thanks for reporting this. I went ahead and double-checked the permissions on the download itself and they are correct. We are seeing hundreds of downloads of the RhinoWIP and can’t seem to reproduce this on our side. We use Amazon’s AWS as the server for the files, which is extraordinarily reliable (I concur with @John_Brock above, this does seem - for lack of more evidence - to be limited to your computer). We also use Amazon’s CloudFront CDN (Content Delivery Network), which may be the source of problems on your computer. Try this link, as it bypasses the CDN (this presumes you have already gotten the licensing email from Brian Gillespie).


#8

Thanks Dan!

The link worked fine for me to download the installer.
Unfortunately, I got stuck with a licence issue. Probably because I am facing the server error on the page where I am entering my Rhino Mac 5 licence code. Consequently, I do not get an email with the Rhino Mac 6 licence code.

… not happening. :confused:

Any other way to get the code without using this page?
Your help is much appreciated.


(Dan Belcher) #9

Oh, sorry, I was reading quickly before and I did not read carefully enough. Now I see your initial report more clearly.

I’m not able to reproduce this on my end. @brian do you have any ideas?


(Brian Gillespie) #10

Server errors are always our fault! The clue we were missing is that @FrankS is downloading from a computer where the language is set to German. Our web site had a bug that didn’t handle the ü character properly, and therefore crashed. That bug is now fixed.

@FrankS, please try downloading again; it should work for you now.


(John Brock) #11

Sorry. It never occurred to me that Frank was using German or that our servers were screwed up with respect to German.


(Brian Gillespie) #12

@John_Brock no need for apologies, but next time you see Server Error, please let me know - it’s a bug we need to fix.


#13

Dear Brian, John, and Dan,

Thanks for your efforts to figure out the root cause of this issue. Much appreciated!

1.) I am not quite there yet, as I am still missing the license code / activated license on CloudZoo.
(more on that later)

2.) Let me point out some aspects of the language issue:
In addition to a WindowPC, I am using a MacBook Pro from which I tried to download Rhino6Mac.
The OSX language setting is English, the same for Chrome. If I had a choice, I’d read/communicate everything related to Rhino/Grasshopper/McNeel in English.

Thing is, the rhino3d.com website is terrible when it comes to language settings:
Changing the languages settings on rhino3d.com is buggy and does not work. It works for the page on which the settings are changed, but then when I click e.g. “downloads” it changes back to German. When I try to change language on the download page, I get redirected to the (English) landing page. There seems to be no way to set the download page that was producing the server error to English.

Pls also refer to my earlier post: Rhino 6 SR2 Release Candidate Available - not available in my preferred language (english)
Another annoying download issue solely related to language settings.

I would not mind, if I could set me user preferences in CloudZoo to English and never have to look at anything German that is related to Rhino again.

Hope you appreciate my feedback.


#14

Now back to the subject (1. (see above))

The download page on rhino3d.com now works in German and no longer produces a server error.

However, I did not receive a license code for Rhino6WIPMac.
As I learned from this post, I am supposed to obtain a license key in an email.

Here is a screenshot of the email I received from @brian.
I guess you guys might not be able to read German but should agree with me that there is no license key in this email.

When I compare this to an email from @Brian for a Rhino6Test for Windows (expired) earlier this year, I get the feeling that something is missing in the Rhino6Mac email.

Is it me? Am I overlooking something?
I know you guys are dealing with a complex setup where things might go wrong from time to time and try to be helpful.
At the same time, I’d love to get my hands on Rhino6WIP for Mac :slight_smile:

Best, Frank


#16

Hi @brian, @John_Brock and @dan

I have the feeling I should give you the executive summary of my last two posts:

  • I am still missing a licence key for Rhino WIP6 for Mac.
  • Can’t find any in the emails from Brian (and I assume it should be in there)

Is there anything that I am missing or do you think this needs fixing on your end?

Thanks for your help!
Frank


(Brian Gillespie) #17

Hi FrankS

If you click the link in #3 from the email, you’ll see how to use your license key.


#18

Hi @brian, @John_Brock

I am still stuck.

No, I don’t. I did not receive a license key!

If I click on link #3 from the email I get to this page, with an option to enter my license key (which I don’t have). When I click on “Where do I find my license key?”, I get to another page telling me, that I should check my email inbox and spam folder. Been there, done that.

Again, I did not receive any license key for RhinoWIP6Mac.
It is not in the email sent by @brian (see above).

I submitted my Rhino5Mac license key more than five times now, received only two replies (and yes, I checked my spam folder) and in these emails there are no license keys! (see screenshot below).

So even if we solve the sending/receiving emails issue,
the content of the email is still missing the most important piece of information (the license key)!

I don’t know how to lay out my situation more clearly and strongly encourage you guys to read carefully and think about how to fix this. I am pretty sure the problem is not on my end. If yes, I’d like to learn what I am doing wrong and apologize in advance.

This is a mess. Please help me to get out of this.


(Brian Gillespie) #19

Hi @FrankS,

I just deployed a new version of the web site that should make this process a lot clearer - can you please try downloading the Mac 6 WIP again?


#20

Thank you @brian,

Now it finally worked!
After entering my V5-Mac license key, I got the V6-WIP-Mac license key on the next page.

Also the email send in your name now finally has the license code.

Remark:
Switching languages is still inconsistent on rhino3d.com.
I can switch to English, but when I click on “downloads”, I am left with German again.

Thanks for the fix!
Frank


#22

https://www.rhino3d.com/download/rhino-for-mac/6/wip

Seems to be a problem (again?):

404 - "Page not Found"


(John Brock) #23

Yes, I see that too.
I just let the product manager know about it.

It should be sorted shortly.