Rhino 6 Performance issues

HI,

Hoping someone can assist…

New machine (Threadripper 3970X, 128GB RAM, 1TB NVME, 1x 2070 Super) for one of our creatives has terrible performance in Rhino 6. He is connecting to this machine via RDP as we are currently all working from home

Checked the NVidia GPU activity and rhino is not listed as an app using the GPU

I confirmed latest NVidia Drivers installed (V442.19)rhino . It also seems its using some generic MS driver. Any idea what that would be?

When running TestMaxSpeed on a fairly small model we get 2fps

Machine details below:

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Commercial, build 2020-02-24
License details: Cloud Zoo. In use by: D*** N*** ()

Windows 10.0 SR0.0 or greater (Physical RAM: 1.3e+02Gb)
Machine name: D***

Non-hybrid graphics.

Secondary graphics devices.
NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 1-29-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: NA
Driver Version: NA
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 64 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Any advise will be greatly appreciated

Hi - In this case, I don’t know if that is the result of the VPN connection, but that information in the SystemInfo data usually means that there’s a problem with the installation of the drivers. Usually, you would want to do a clean install of the latest drivers on that machine (i.e. completely uninstall all GPU drivers and install new ones). There’s a complete recipe for doing that here:


Make sure to include step 4 of the uninstalling process!

Apart from that, since the license is in the Cloud Zoo, it might make sense to run Rhino on the local machine.
-wim

Thanks Wim,

When you say run Rhino locally, what do you mean by that? Does Cloud Zoo not only allow the machine to fetch a license? The user is running Rhino on the machine he RDPs onto since its more powerful than the laptop he uses to RDP from

Thanks,

Hi - I understand that the machine that he RDPs into is more powerful but because of either problems with the installation of display drivers on that machine or because of the RDP-ing itself, that is not turning out very well. None of that power is being used. If you can fix that (probably by clean installing new drivers but that might require a trip to the office(?)), then fine. If not, running Rhino locally on the laptop at home would probably be the better option.

Did you read through this thread?

-wim

I have not actually :smiley:

Let me have a read and update our findings accordingly