Rhino 6 Layout Technical Print ignoring surfaces

Version 6 SR10
(6.10.18311.20531, 7/11/2018)

On the Layout view, I have a collection of Technical Detail objects. When printing, the print preview ignores some surfaces, and the generated PDF file also ignores those surfaces.

The West Elevation is ignoring the 2 lower wall wall surfaces, thus allowing internal walls and the staircase to be visible.

The North Elevation is ignoring the 2 lower wall wall surfaces, thus allowing internal walls to be visible.



Regards, Garry.

Are they “bad” surfaces?
Does SelBadObjects select them?

The surfaces have to generate valid render meshes or the “Technical View” magic doesn’t work.

Hi John. The surfaces in question are OK. The image below shows that there are 10 bad surfaces and 7 bad polysurfaces, but they are on the upper level. The ignored surfaces are the external walls on the lower level either side of the closest corner in the attached image.

As shown in my earlier image, the Technical view correctly displays in the Layout. It is only the Print facility which has the problem.

Regards, Garry.

Do you get the correct output if you set the print output to raster instead of vector?

Hi Steve. Same problem. See attached. Changing to a physical printer also has no effect.


I have repaired the bad surfaces, but the Print problem still exists.

Regards, Garry.


did you check surface backface normals?

Hi Garry - if you hide all but these non-printing objects and then print, do they show or is the print blank? If they do not show, can you please delete all but those objects and SaveAs and post here send us the file? (tech@mcneel.com)


I am not sure whether you are referencing a check box setting, or whether you are suggesting a check scan of objects. I have found references to backface in the documentation, but cannot find anywhere to adjust its settings for an individual surface. As you will see below, the Options setting for Backface is ‘Use front face settings’.

I ran Analyse | Diagnostics | Check, and all objects are valid.


I have attached the material details for one of the ignored objects.


I have attached my settings for Technical view.


Here is the Object Description for the same ignored surface:


ID: ea6d28fe-23bf-44b4-b1cd-50dde258f2e6 (3124)
Object name: (not named)
Layer name: Shell Lower A::SLA Endeavour
Render Material:
source = from obj
index = 1688
Attribute UserData:
UserData ID: CE28DE29-F4C5-4faa-A50A-C3A6849B6329
Plug-in: 17b3ecda-17ba-4e45-9e67-a2b8d9be520d
description: User text (0 entries)
saved in file: yes
copy count: 51

Valid surface.
Trimmed surface with 1 hole(s).
NURBS Surface
“U”: degree =1 CV count = 2 (0 <= U <= 90)
“V”: degree =1 CV count = 2 (0 <= V <= 43.8)
Edge Tally:
13 boundary edges
Edge Tolerances: all 0
Vertex Tolerances: all 0
Render mesh: 1 basic custom mesh 78 vertices 74 polygons
Analysis mesh: none present
Geometry UserData:
UserData ID: 6ADBBF65-A1D4-4d54-A0C8-BFAAB1A6086D
description: Technical Drawing Data
saved in file: no
copy count: 1

Hi Pascal.

I have only the 4 ignored surfaces active. As you can see, the Detail Technical views show the surfaces, but the Print Preview is blank.

I have attached the 3dm and pdf files. I deleted the materials in order to reduce the file size. Happy hunting.

HouseRemodelFIgnoredSurfaces.3dm (395.5 KB)

HouseRemodelFIgnoredSurfaces.pdf (3.1 KB)

Regards, Garry.

Hi Garry - those objects are set to No Print in their Properties:



Thank you Pascal. I did not think along those lines. I suppose I was blindly assuming that the printed output would be what I saw on the view. Lesson learned. I will now look for a somewhere to hide!

Hi Garry - no worries - turning on PrintDisplay will save some head scratching too.