Rhino 6 bug - focal blur

Focal blur makes surfaces invisible in Raytraced display mode. It does not influence other display modes.
focal%20blur%20bug

Try for aperture a smaller value, like 1. Your objects are quite a bit out of focus, likely.

I suppose the different usages of values can be considered a bug (Raytraced vs Rhino Render)

It makes no difference.

Please attach a file that exhibits your problem.

I see this with a quick test:

I used perspective view. Everything looks sharp in every file. Changing focal distance and aperture makes no difference.

As you can see from my screenshot I also use perspective view with Raytraced mode.

A file would still be appreciated so we can see what is going on.

cuboid.3dm (4.3 MB)

The focal distance of 1 for your file means a point very close to the camera. That means rays will scatter quite a bit before they reach the box, resulting in a very out of focus image.

Use the focal distance selection button to pick one or more points to get a good distance to your object, then it will be much easier to tweak settings afterwards:

Also note that focal blur does have no effect in any of the other display modes…

I used the same file and the same settings - still no blur.

In Raytraced?

I understand a bit what he is seeing, see the vid below. If you hit Autofocus, nothing seems to happen - by the way I don’t understand what it means to autofocus to selected objects for as soon as you select, the settings tab disappears and goes back to object properties. When I hit Manual Focus, the object disappears completely with the default setting - I guess this will depend on the scene, but seems like there needs to be an initial setting based on the scene that at least allows you to see some objects.

If I start poking the settings, I can zero in on a result. So I obviously don’t know how to work this thing correctly, but honestly this the first time I have ever tried…

Auto-focus isn’t supported, and it is unclear it ever will. See: https://mcneel.myjetbrains.com/youtrack/issue/RH-41177 .

@Helvetosaur it is indeed a bit hard to get good values, also because focus works a bit different between Rhino Render and Raytraced. Let me know if you have suggestions how to improve. Better initial settings, but how should we determine those? Whole visible scene midpoint, aperture maybe 0?

What video format is that? FF Nightly on MacOS doesn’t recognize that. nvm, I can just right-click the element and choose play video from the context menu. That opens the link to the video.

in rendered view
In raytraced view I can barely see the cuboid regardless of the settings because it is very blurred.
Helvetosaur gets sharp view of the cuboid at some settings in the rendered view. I do not.

@Andrew_Nowicki, in the video by @Helvetosaur you see the Raytraced mode, not Rendered. And as I said before, Rendered doesn’t support focal blur.

Rhino documentation does not mention this fact.

“The focal blur settings apply only to Perspective viewports.” source: https://docs.mcneel.com/rhino/6/help/en-us/index.htm#properties/focalblur.htm?Highlight=blur

Reported as RH-43997. Thanks for letting us know.

I have got it! I get sharp edges when I reduce aperture to 0.1. When I set the aperture to 0.5 the blur is close to optimal. There is a user interface bug in the aperture: the arrows change the aperture too much at low settings. (Linear and rotational motion blur would be as useful as the focal blur )

Maybe remove it from the panel then until it is? Why confuse users?

Dunno, I’m a complete novice/idiot with this stuff…

It’s an MP4. I think it’s probably just not mac-ish enough. :stuck_out_tongue:

It actually fails to load in FF Nightly on Windows 10 as well…

That is what the YT item is about I linked to earlier.